php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58821 Broken compilation under Windows XP, VC9, non-thread-safe
Submitted: 2009-08-21 10:11 UTC Modified: 2009-10-22 02:23 UTC
From: michal dot kocarek at brainbox dot cz Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: HEAD CVS-2009-08-21 (dev) OS: Windows XP Pro (x86 VC9)
Private report: No CVE-ID: None
 [2009-08-21 10:11 UTC] michal dot kocarek at brainbox dot cz
Description:
------------
When compiling non-thread-safe version of PHP 5.3 with HTTP extension, compilation fails in file http_request_pool_api.c.

Compiled on Windows XP, VC9, x86, as RELEASE (not debug), non-thread-safe.

Reproduce code:
---------------
buildconf
configure --with-php-build=".." --disable-all --disable-zts --enable-http --enable-cli
# important is --enable-http and --disable-zts
nmake

Problem is only for non-thread-safe. thread-safe is OK.

Problem is caused by lines 112, 149 and 410, where following call occurs:
TSRMLS_FETCH_FROM_CTX(?);
and is immediately followed by getObjectEx(?) call.

I ?fixed? the error by enclosing the TSRMLS_FETCH_? command with #if ZTS and #endif, and after I am able to compile happily. (This is not problably the real fix, but I am telling to give a hint where the problem could be).

Expected result:
----------------
Compilation should success.

Actual result:
--------------
Compilation fails.

First error in compiler output is

ext\pecl_http\http_request_pool_api.c(113) : error C2143: syntax error : missing ';' before 'type'

This line is followed by other unimportant errors (first error causes syntax problems which raise other errors).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-22 02:23 UTC] mike@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

Thanks Pierre.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 21:03:39 2021 UTC