php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58804 APC Wont compile - complains about missing apc_bin.h
Submitted: 2009-08-13 15:09 UTC Modified: 2009-08-14 07:11 UTC
From: lists at reptiliannature dot org Assigned:
Status: Closed Package: APC (PECL)
PHP Version: HEAD CVS-2009-08-13 (dev) OS: Ubuntu - lenny/sid
Private report: No CVE-ID: None
 [2009-08-13 15:09 UTC] lists at reptiliannature dot org
Description:
------------
I got the tar ball and unpacked it.
I ran phpize, then ./configure --enable-apc --enable-apc-mmap --with-apxs --with-php-config=/usr/local/php/php5.3RC3/bin/php-config.

next i ran make

I had gotten a No such file or directory for file apc_bin.h
when the compiler was working on php_apc.lo

Reproduce code:
---------------
 cc -I. -I/src/php/php-5.3.0/modules/APC-3.1.3 -DPHP_ATOM_INC -I/src/php/php-5.3.0/modules/APC-3.1.3/include -I/src/php/php-5.3.0/modules/APC-3.1.3/main -I/src/php/php-5.3.0/modules/APC-3.1.3 -I/usr/local/php/php5.3RC3/include/php -I/usr/local/php/php5.3RC3/include/php/main -I/usr/local/php/php5.3RC3/include/php/TSRM -I/usr/local/php/php5.3RC3/include/php/Zend -I/usr/local/php/php5.3RC3/include/php/ext -I/usr/local/php/php5.3RC3/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /src/php/php-5.3.0/modules/APC-3.1.3/apc.c  -fPIC -DPIC -o .libs/apc.o
/bin/bash /src/php/php-5.3.0/modules/APC-3.1.3/libtool --mode=compile cc  -I. -I/src/php/php-5.3.0/modules/APC-3.1.3 -DPHP_ATOM_INC -I/src/php/php-5.3.0/modules/APC-3.1.3/include -I/src/php/php-5.3.0/modules/APC-3.1.3/main -I/src/php/php-5.3.0/modules/APC-3.1.3 -I/usr/local/php/php5.3RC3/include/php -I/usr/local/php/php5.3RC3/include/php/main -I/usr/local/php/php5.3RC3/include/php/TSRM -I/usr/local/php/php5.3RC3/include/php/Zend -I/usr/local/php/php5.3RC3/include/php/ext -I/usr/local/php/php5.3RC3/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c -o php_apc.lo
 cc -I. -I/src/php/php-5.3.0/modules/APC-3.1.3 -DPHP_ATOM_INC -I/src/php/php-5.3.0/modules/APC-3.1.3/include -I/src/php/php-5.3.0/modules/APC-3.1.3/main -I/src/php/php-5.3.0/modules/APC-3.1.3 -I/usr/local/php/php5.3RC3/include/php -I/usr/local/php/php5.3RC3/include/php/main -I/usr/local/php/php5.3RC3/include/php/TSRM -I/usr/local/php/php5.3RC3/include/php/Zend -I/usr/local/php/php5.3RC3/include/php/ext -I/usr/local/php/php5.3RC3/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c  -fPIC -DPIC -o .libs/php_apc.o
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:37:21: error: apc_bin.h: No such file or directory
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c: In function 'zm_startup_apc':
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:272: error: 'APC_BIN_VERIFY_MD5' undeclared (first use in this function)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:272: error: (Each undeclared identifier is reported only once
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:272: error: for each function it appears in.)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:273: error: 'APC_BIN_VERIFY_CRC32' undeclared (first use in this function)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c: In function 'zif_apc_bin_dump':
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1313: error: 'apc_bd_t' undeclared (first use in this function)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1313: error: 'bd' undeclared (first use in this function)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c: In function 'zif_apc_bin_dumpfile':
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1351: error: 'apc_bd_t' undeclared (first use in this function)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1351: error: 'bd' undeclared (first use in this function)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c: In function 'zif_apc_bin_load':
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1429: error: 'apc_bd_t' undeclared (first use in this function)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1429: error: expected expression before ')' token
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1430: error: expected expression before ')' token
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1434: error: expected expression before ')' token
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c: In function 'zif_apc_bin_loadfile':
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1482: error: 'apc_bd_t' undeclared (first use in this function)
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1482: error: expected expression before ')' token
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1483: error: expected expression before ')' token
/src/php/php-5.3.0/modules/APC-3.1.3/php_apc.c:1488: error: expected expression before ')' token


Expected result:
----------------
a compiled apc install

Actual result:
--------------
error on compilation

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-13 19:29 UTC] desfrenes at gmail dot com
Same here, using pecl install under ubuntu.
 [2009-08-13 19:44 UTC] desfrenes at gmail dot com
Fetching apc_bin.h and apc_bin.c from svn fixed it.
 [2009-08-14 06:47 UTC] gopalv82 at yahoo dot com
My bad, my bad.

Let me put out a _p1 today itself. 

I aim at making 3.1.4 a stable release (due to some irrational reasons I shall not go into).

So feel free to pile on the bugs ... or poke me on irc (g0pz on #php.pecl)
 [2009-08-14 07:11 UTC] gopalv82 at yahoo dot com
http://pecl.php.net/package/APC/3.1.3p1

yet again, sorry!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 02:03:37 2021 UTC