php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58792 newt compile error with php 5.3
Submitted: 2009-08-05 07:41 UTC Modified: 2009-08-06 02:48 UTC
From: husen at fiare dot fi Assigned:
Status: Closed Package: newt (PECL)
PHP Version: 5_3 CVS-2009-08-05 (dev) OS: kubuntu
Private report: No CVE-ID: None
 [2009-08-05 07:41 UTC] husen at fiare dot fi
Description:
------------
Receiving below error while trying to install newt current stable version with php 5.3. Not sure whether something wrong with my setup or it's due to the problem with newt. Please suggest.

/download/php/pecl/newt/newt-1.2.1/newt.c: In function 'zif_newt_set_suspend_callback':
/download/php/pecl/newt/newt-1.2.1/newt.c:899: error: too few arguments to function 'zend_is_callable'
/download/php/pecl/newt/newt-1.2.1/newt.c: In function 'zif_newt_set_help_callback':
/download/php/pecl/newt/newt-1.2.1/newt.c:939: error: too few arguments to function 'zend_is_callable'
/download/php/pecl/newt/newt-1.2.1/newt.c: In function 'zif_newt_entry_set_filter':
/download/php/pecl/newt/newt-1.2.1/newt.c:2694: error: too few arguments to function 'zend_is_callable'
/download/php/pecl/newt/newt-1.2.1/newt.c: In function 'zif_newt_component_add_callback':
/download/php/pecl/newt/newt-1.2.1/newt.c:2814: error: too few arguments to function 'zend_is_callable'
make: *** [newt.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-05 09:54 UTC] spektom at gmail dot com
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/newt

Fixed in 1.2.2 (there were compilation issues with 'thread 
safety' enabled)
 [2009-08-06 02:48 UTC] husen at fiare dot fi
looks ok now. 

Thanks & Regards.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 22:01:23 2020 UTC