php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58787 Memcached compression
Submitted: 2009-08-02 14:35 UTC Modified: 2012-03-07 17:18 UTC
From: matrix at alpha-force dot net Assigned: andrei (profile)
Status: Closed Package: memcached (PECL)
PHP Version: 5.3.0RC4 OS: Debian
Private report: No CVE-ID: None
 [2009-08-02 14:35 UTC] matrix at alpha-force dot net
Description:
------------
Hi,

Whenever I want to set something in the Memcached that is longer than 100 chars, I get a "502 Bad Gateway" error from nginx web server. I have narrowed this down to transparent compression of data larger than 100 B. If I turn off the compression, the data stores normally.

Configure line for memcached:
./configure\
 --enable-memcached \
--disable-memcached-session \
--with-php-config=/opt/php/bin/php-config

libmemcache is from debian repository.
libmemcached2  0.31-1

PHP 5.3.0 final was compiled with:
./configure \
--prefix=/opt/php \
--disable-libxml \
--disable-simplexml \
--disable-xml \
--disable-xmlreader \
--disable-xmlwriter \
--disable-dom \
--disable-ipv6 \
--without-iconv \
--disable-json \
--disable-pdo \
--disable-mbregex \
--disable-posix \
--disable-phar \
--enable-mbstring \
--enable-intl \
--without-pear \
--without-sqlite \
--without-sqlite3 \
--with-mysqli=mysqlnd \
--with-mcrypt=/usr/bin/mcrypt \




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-02 17:10 UTC] matrix at alpha-force dot net
The problem is solved by compiling PHP with zlib support (--with-zlib). Perhaps Memcached should check if zlib is enabled.
 [2012-03-07 17:18 UTC] andrei@php.net
Closing because of age. Please try version 2.0.1 and reopen if this still occurs.
 [2012-03-07 17:18 UTC] andrei@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: andrei
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC