php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58780 Segmentation fault with imagick and ZendOptimizer
Submitted: 2009-07-30 12:06 UTC Modified: 2009-07-30 12:27 UTC
From: geoff dot garside at openhosting dot co dot uk Assigned:
Status: Not a bug Package: imagick (PECL)
PHP Version: 5.2.10 OS: FreeBSD 6
Private report: No CVE-ID: None
 [2009-07-30 12:06 UTC] geoff dot garside at openhosting dot co dot uk
Description:
------------
Build PHP 5.2.10, ImagicMagick 6.5.3.10 and ZendOptimizer 
v3.3.0. Build imagick extension and enable. Run php and you'll 
get a segmentation fault.

I've not tried this with a debug version of PHP, though I will 
attempt this later.

Reproduce code:
---------------
## php.ini
extension=imagick.so

[Zend]
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer="/usr/local/lib/php/20060613/Optimizer"
zend_extension_manager.optimizer_ts="/usr/local/lib/php/20060613/Optimizer_TS"
zend_extension="/usr/local/lib/php/20060613/ZendExtensionManager.so"
zend_extension_ts="/usr/local/lib/php/20060613/ZendExtensionManager_TS.so"

## On shell
php -c php.ini -i


Expected result:
----------------
PHP 5.2.10 (cli) (built: Jul 30 2009 15:54:28) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-
2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by 
Zend Technologies


Actual result:
--------------
PHP 5.2.10 (cli) (built: Jul 30 2009 15:54:28) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-
2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by 
Zend Technologies
Segmentation fault (core dumped)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-30 12:09 UTC] mkoppanen@php.net
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

Reopen if this happens without ZendOptimizer.
 [2009-07-30 12:17 UTC] geoff dot garside at openhosting dot co dot uk
Thanks, sometimes I wonder why I bother
 [2009-07-30 12:21 UTC] mkoppanen@php.net
ZendOptimizer is a commercial closed source product. If the issue is related to ZendOptimizer there is really nothing I or any PHP developer can do.

If the issue is reproducible without ZendOptimizer I can probably reproduce and fix it.
 [2009-07-30 12:24 UTC] geoff dot garside at openhosting dot co dot uk
Its not a slant at you, I would try to contact Zend about the 
issue but I've done so in the past and my efforts have had no 
results.
 [2009-07-30 12:27 UTC] mkoppanen@php.net
If this can not be reproduced without ZendOptimizer I am afraid I can't help you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC