php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #58778 licence used prevents integration in Debian
Submitted: 2009-07-29 10:25 UTC Modified: 2017-10-24 09:10 UTC
From: tg at mirbsd dot de Assigned:
Status: Suspended Package: perl (PECL)
PHP Version: 5.2.4 OS: Debian
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2009-07-29 10:25 UTC] tg at mirbsd dot de
Description:
------------
php-perl uses version 3.0 of the PHP licence, not version
3.01 which was designed to work around the problem of
Debian integration.

I already mailed about this but didn’t get any real
response, and http://svn.php.net/viewvc/pecl/perl/trunk/
clearly shows the licence hasn’t been changed since.

(Of course, I’m still in favour of using a BSD licence,
but Debian said PHP Licence 3.01 would probably suffice;
possibly combine it with an explicit OK to link it with
libperl.)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-10-24 09:10 UTC] kalle@php.net
-Status: Open +Status: Suspended
 [2017-10-24 09:10 UTC] kalle@php.net
The perl package has had no activity for at least 4 years, so I'm gonna consider it dead. If a new maintainer decides to pick this back up, he/she can re-open the report
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 24 09:01:24 2020 UTC