php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58745 does not compile statically
Submitted: 2009-07-01 07:12 UTC Modified: 2011-09-21 13:09 UTC
From: guenter at grodotzki dot ph Assigned:
Status: Closed Package: ssh2 (PECL)
PHP Version: 5_3 CVS-2009-07-01 (dev) OS: Debian Lenny
Private report: No CVE-ID:
 [2009-07-01 07:12 UTC] guenter at grodotzki dot ph
Description:
------------
tried to compile ssh2 statically into php5.3.0, but I get an error

Reproduce code:
---------------
# cd ext
# wget http://pecl.php.net/get/ssh2-0.11.0.tgz && tar xvfz ssh2-0.11.0.tgz && mv package.xml ssh2-0.11.0 && mv ssh2-0.11.0 ssh2 && rm ssh2-0.11.0.tgz
# rm configure
# ./buildconf --force
# ./configure \
--prefix=/usr \
--with-config-file-path=/etc/php5/cgi \
--with-bz2 \
--with-curl \
--with-freetype-dir \
--with-gd \
--with-jpeg-dir \
--with-kerberos \
--with-mcrypt \
--with-mysql=mysqlnd \
--with-openssl \
--with-png-dir \
--with-ssh2 \
--with-zlib \
--enable-gd-native-ttf \
--enable-libxml \
--enable-mbstring \
--enable-sqlite-utf8 \
--enable-xml \
--disable-cli

Expected result:
----------------
no-error

Actual result:
--------------
/ssh2.c -o ext/ssh2/ssh2.lo 
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:52: error: duplicate 'static'
/usr/src/php-5.3.0/ext/ssh2/ssh2.c: In function 'zif_ssh2_methods_negotiated':
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:503: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:504: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:508: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:509: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:510: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:511: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:516: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:517: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:518: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:519: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c: In function 'zif_ssh2_publickey_add':
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:1045: warning: passing argument 1 of '_efree' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c: In function 'zif_ssh2_publickey_list':
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:1104: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/usr/src/php-5.3.0/ext/ssh2/ssh2.c:1105: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
make: *** [ext/ssh2/ssh2.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-12 15:40 UTC] Fedora at famillecollet dot com
Patch proposal for PHP 5.3.0

http://remi.fedorapeople.org/ssh2-php53.patch

+
 [2009-07-13 04:55 UTC] christian dot ubu at NOTSPAM dot gmail dot com
Thank you remi.
Your patch did the job for me :)
 [2009-09-11 09:18 UTC] luciocfgodoy at hotmail dot com
It worked for me as well, many thanks

PHP 5.3

LG
 [2009-10-07 03:49 UTC] moayad at gmail dot com
i have same problem, How to patch the file?
 [2010-01-23 16:25 UTC] vid at thirdpartycode dot com
works for me too. for the person looking to apply the patch. 

do patch -p0 < nameofpatchfile
 [2010-03-14 11:10 UTC] gocoffeecup at gmail dot com
unfortunatly this patch isnt working for me on Linux version 2.6.32-trunk-686 (Debian 2.6.32-5) (ben@decadent.org.uk) (gcc version 4.3.4 (Debian 4.3.4-6) )  :(
 [2010-03-14 11:31 UTC] gocoffeecup at gmail dot com
i'm sorry i didnt notice that i can also use the package libssh2-php on debian and dont have to compile it myself, it works like a charm now
 [2010-08-12 03:12 UTC] m dot schmid at allgaeukraft dot de
Applying the patch worked also under a "standard" PHP 5.3 installation (via apt-get) on a Ubuntu 10.04 (Lucid Lynx) server.

Thanks.
 [2011-09-21 13:09 UTC] bjori@php.net
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/ssh2

This was fixed long time ago
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 15:02:26 2014 UTC