php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58744 php5.dll was not found in thread safe php.
Submitted: 2009-07-01 06:13 UTC Modified: 2013-02-07 16:55 UTC
Votes:3
Avg. Score:4.7 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:3 (100.0%)
From: gyoung dot hwa dot kim at gmail dot com Assigned:
Status: Not a bug Package: PECL bug system (PECL)
PHP Version: 5.2.10 OS: window
Private report: No CVE-ID: None
 [2009-07-01 06:13 UTC] gyoung dot hwa dot kim at gmail dot com
Description:
------------
I installed Apache 2.0, php-5.2.10-Win32.zip, db2 Express C. I followed all the instructions to set up php and phpinfo() can be displayed from the web page. I wrote a test.php which connects to a DB2 database and ran it with "php test.php". It failed with the following error message. 
"This application has failed to start because php5.dll was not found. Re-installing the application may fix this problem."  In PHP directory, I have php5ts.dll not php5.dll. 

From the dependency walker, php.exe should look for php5ts.dll. 

Because of the error, I installed php-5.2.10-nts-Win32.zip, this time I got error from apache saying "apache is running thread safe mode, and php is not in thread safe mode, so php cannot be started." 

So both of them didn't work with apache. 

Reproduce code:
---------------
test.php source code

<?php
$conn = db2_connect('sample', 'userid', 'password');
if ($conn) {
    echo "Connection succeeded.\n";
    if (db2_autocommit($conn)) {
         echo "Autocommit is on.\n";
    }
    else {
         echo "Autocommit is off.\n";
    }
    db2_close($conn);
}
else {
    echo "Connection failed.";
}

$create = 'DROP TABLE xmlTest';
$result = db2_exec($conn, $create);
$create = 'CREATE TABLE xmlTest (id INTEGER, data XML)';
$result = db2_exec($conn, $create);
$insert = "INSERT INTO xmlTest values (0,
'<Client><Address><street>555 Bailey Ave</street><city>San
Jose</city><state>CA</state><zip>95141</zip></Address><email>ranjanr
@us.ibm.com</email></Client>')";
db2_exec( $conn, $insert );
if ($conn) {
$sql = "SELECT data FROM xmlTest";
$stmt = db2_prepare( $conn, $sql );
db2_execute($stmt);
while($result = db2_fetch_assoc($stmt)) {
print_r($result);
echo "\n";
}
db2_close($conn);
} else {
echo "Connection failed.\n";
}
?

Expected result:
----------------
I expected the connection to db2 is established. 

Actual result:
--------------
failed with errors. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-06 16:53 UTC] tyrael@php.net
-Status: Open +Status: Not a bug
 [2013-01-06 16:53 UTC] tyrael@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2013-02-06 22:47 UTC] christian at cybernet1 dot com
I am having a similar issue with php5.4.11, when trying to execute php.exe, php-win.exe or php-cgi.exe I get php5.dll is missing.

This is a Windows IIS 7.5 server, phpinfo loads fine on any of the websites stating the version 5.4.11 and thread safety is enabled.  

Any help would be appreciated.  

Thanks,
-Christian
 [2013-02-07 07:50 UTC] pajoye@php.net
@christian at cybernet1 dot com

php5.dll > NTS
php5ts.dll > thread safe

For IIS you should use NTS builds. Be sure to do not leave bad settings or wrong 
php.ini, it can lead to try to load thread safe extensions while you use NTS, or 
the other way round.

No bug here.
 [2013-02-07 15:29 UTC] christian at cybernet1 dot com
I've actually just been trying to install a ffmpeg extension for some websites I host, it doesn't work in the non thread safe version from what I can tell, so am I just kind of out of luck?

Thanks,
Christian
 [2013-02-07 15:40 UTC] christian at cybernet1 dot com
And now the nts version is saying it can't find the php5ts.dll...
 [2013-02-07 15:53 UTC] pajoye@php.net
You are loading the wrong version. However bugs.php.net is not a support channel, 
and ffmpeg is not under php.net, sorry.
 [2013-02-07 16:38 UTC] christian at cybernet1 dot com
FFMPEG hasn't even come in to the picture yet, and I don't see how I could be loading the wrong version when it's straight from the zip file php-5.4.11-nts-Win32-VC9-x86.zip
 [2013-02-07 16:55 UTC] pajoye@php.net
All extensions are tested and loaded. Also it is literally impossible to build TS 
and NTS at the same time. Check your php.ini or config, something is wrong there.

I would suggest php-install or php-windows mailing list.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 04:03:34 2021 UTC