php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58733 cannot configure ibm_db2 1.8.2
Submitted: 2009-06-22 13:42 UTC Modified: 2009-06-23 12:01 UTC
From: d dot stcyr at streamfoundry dot com Assigned:
Status: Closed Package: ibm_db2 (PECL)
PHP Version: 5.2.9 OS: Linux SLES10
Private report: No CVE-ID: None
 [2009-06-22 13:42 UTC] d dot stcyr at streamfoundry dot com
Description:
------------
Downloaded and untar'd ibm_db2-1.8.2.tgz.

phpize ran OK but can't configure - getting: 

"configure: error: Cannot find php-config. Please use --with-php-config=PATH"

even though the configure already has --with-php-config coded. 



Reproduce code:
---------------
Configure command used:

# ./configure --with-IBM_DB2=/opt/ibm/db2/V9.5 --with-php-config=/opt/SFI/php-5.2.9/scripts

This shows that php-config is actually there.
# find / -name php-config
/opt/SFI/php-5.2.9/scripts/php-config

Within /opt/SFI/php-5.2.9/scripts/php-config, the prefix setting is obviously there:
   prefix="/usr"
along with all other config data.

Expected result:
----------------
successful configure

Actual result:
--------------
"configure: error: Cannot find php-config. Please use --with-php-config=PATH"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-23 01:35 UTC] abhargav at in dot ibm dot com
Hi,

Use ./configure --with-IBM_DB2=/opt/ibm/db2/V9.5
--with-php-config=/opt/SFI/php-5.2.9/scripts/php-config

If you use only --with-php-config=/opt/SFI/php-5.2.9/scripts (without adding php-config into it), you get the error mentioned by you.

Regards,
Ambrish Bhargava
 [2009-06-23 07:30 UTC] d dot stcyr at streamfoundry dot com
Ambrish - thanks for responding - I thought "--with-php-config=" was to specify a path so that's how I reported it. I  already tried including the php-config file name and got the same result. I tried it 3 ways:

# ./configure --with-IBM_DB2=/opt/ibm/db2/V9.5
--with-php-config=/opt/SFI/php-5.2.9/scripts

# ./configure --with-IBM_DB2=/opt/ibm/db2/V9.5
--with-php-config=/opt/SFI/php-5.2.9/scripts/

# ./configure --with-IBM_DB2=/opt/ibm/db2/V9.5
--with-php-config=/opt/SFI/php-5.2.9/scripts/php-config

all continued to produce the error saying "Cannot find php-config".

Dan
 [2009-06-23 12:01 UTC] d dot stcyr at streamfoundry dot com
Typical user error - my php-config file was really at /usr/bin/php-config5 - after changing my configure to:

# ./configure --with-IBM_DB2=/opt/ibm/db2/V9.5
--with-php-config=/usr/bin/php-config5

the make install worked fine.

Thanks for the time, Ambrish.

Dan St.Cyr
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Nov 23 02:01:24 2019 UTC