php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58706 unable to compile intl
Submitted: 2009-05-28 15:29 UTC Modified: 2012-07-25 08:19 UTC
From: philip@php.net Assigned:
Status: Not a bug Package: intl (PECL)
PHP Version: 5.3.0RC2 OS: Mac OS X 10.5
Private report: No CVE-ID: None
 [2009-05-28 15:29 UTC] philip@php.net
Description:
------------
Compiling intl for 5.3.0 RC2 as 64 bit on a Mac is failing.

Let me know how to further test this.

icu-config --version ... 4.0

Reproduce code:
---------------
The relevant configure options, From config.nice:

CFLAGS='-arch x86_64 -g -Os -pipe -no-cpp-precomp' \
CXXFLAGS='-arch x86_64 -g -Os -pipe' \
LDFLAGS='-arch x86_64 -bind_at_load' \
'./configure' \
'--with-icu-dir=/opt/local' \
'--enable-intl' \
'--enable-mbstring' \
"$@"

Also set although it (without --with-icu-dir) doesn't appear to do anything useful, but that's likely a different issue:

$ export LD_LIBRARY_PATH=/opt/local 


Actual result:
--------------
So after a successful configure, make ends up with:

...
cp libs/libphp5.bundle libs/libphp5.so
Undefined symbols:
  "___gxx_personality_v0", referenced from:
      EH_frame1 in msgformat_helpers.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [libs/libphp5.bundle] Error 1


Removing --enable-intl solves the problem.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-11 17:34 UTC] crxgames at gmail dot com
I too can confirm this. I have the exact same problem.
 [2009-06-17 10:43 UTC] davidpersson at gmx dot de
I can also confirm this on the same platform using 5.3.0RC3.
 [2009-07-09 21:07 UTC] info at mabwebdesign dot com
I can confirm the same problem on 10.5.6 w/5.3
 [2010-05-24 15:17 UTC] stas at zend dot com
See here for workarounds:

http://bugs.php.net/bug.php?id=48795
 [2012-07-25 08:19 UTC] cataphract@php.net
-Status: Open +Status: Not a bug
 [2012-07-25 08:19 UTC] cataphract@php.net
Closing as I assume this is no longer a problem.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 22:01:26 2019 UTC