php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58660 PHPScript cannot be compiled
Submitted: 2009-05-03 13:00 UTC Modified: 2017-04-01 21:26 UTC
From: miau dot jp at gmail dot com Assigned:
Status: Wont fix Package: PHPScript (PECL)
PHP Version: 5_3 CVS-2009-05-03 (dev) OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2009-05-03 13:00 UTC] miau dot jp at gmail dot com
Description:
------------
When I compile PHPScript, I get the error below.

ext\activescript\scriptengine.cpp(2031) : error C2660: 'zend_exception_error' : function does not take 2 arguments

I follow the blog to compile it.

http://blog.harddisk.is-a-geek.org/index.php/dev/php/php-on-windows/


Reproduce code:
---------------
Index: scriptengine.cpp
===================================================================
RCS file: /repository/pecl/activescript/scriptengine.cpp,v
retrieving revision 1.19
diff -u -r1.19 scriptengine.cpp
--- scriptengine.cpp	4 Dec 2005 15:48:26 -0000	1.19
+++ scriptengine.cpp	3 May 2009 16:46:58 -0000
@@ -2028,7 +2028,7 @@
 	
 	/* ugly way to detect an exception for an eval'd fragment */
 	if (type == E_ERROR && EG(exception) && strstr("Exception thrown without a stack frame", format)) {
-		zend_exception_error(EG(exception) TSRMLS_CC);
+		zend_exception_error(EG(exception), E_ERROR TSRMLS_CC);
 		/* NOTREACHED -- recursive E_ERROR */
 	} else {
 		buflen = vspprintf(&buf, PG(log_errors_max_len), format, args);



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:26 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:26 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 22:01:23 2020 UTC