php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58652 class extends+implements crashes
Submitted: 2009-04-27 15:59 UTC Modified: 2017-07-24 21:35 UTC
From: spam04 at pornel dot net Assigned: colinodell (profile)
Status: Closed Package: inclued (PECL)
PHP Version: 5_3 CVS-2009-04-27 (dev) OS: Mac OS X 10.5.6
Private report: No CVE-ID: None
 [2009-04-27 15:59 UTC] spam04 at pornel dot net
Description:
------------
Reproducible crash.

Reproduce code:
---------------
<?php

class b
{}

interface c
{}


class a
extends b
implements c
{
}


Actual result:
--------------
Process:         php [56651]
Path:            /usr/local/bin/php
Identifier:      php
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  bash [23158]

Date/Time:       2009-04-27 20:58:01.342 +0100
OS Version:      Mac OS X 10.5.6 (9G55)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000001e9f04c
Crashed Thread:  0

Thread 0 Crashed:
0   inclued.so                    	0x00f85a02 
inclued_op_ZEND_ADD_INTERFACE + 50 (inclued_zend.c:278)
1   php                           	0x002f6884 
_ZEND_USER_OPCODE_SPEC_HANDLER + 36
2   php                           	0x002f6385 execute + 
485
3   php                           	0x002c86a6 
zend_execute_scripts + 102
4   php                           	0x0026dae8 
php_execute_script + 392
5   php                           	0x003565a4 main + 
4660
6   php                           	0x00002776 start + 
54

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x00f15fe0  ebx: 0x00f859db  ecx: 0x00f89020  edx: 
0x00f8906c
  edi: 0x00771c80  esi: 0x00f146a0  ebp: 0xbfffeb68  esp: 
0xbfffeb10
   ss: 0x0000001f  efl: 0x00010282  eip: 0x00f85a02   cs: 
0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 
0x00000037
  cr2: 0x01e9f04c

Binary Images:
    0x1000 -   0x710fff +php ??? (???) 
<1010abcea1064b7e10cc20529597e91c> /usr/local/bin/php
  0x7e2000 -   0x7eefff +libexslt.0.dylib ??? (???) 
<0a3a37be456d7c4944b630d221fd92f9> /sw/lib/libexslt.0.dylib
  0x7f7000 -   0x8eefe2 +libiconv.2.dylib ??? (???) 
<3b614337bce449b053db2e3bbfe1ec3a> /sw/lib/libiconv.2.dylib
  0x907000 -   0x90efd3 +libintl.3.dylib ??? (???) 
/sw/lib/libintl.3.dylib
  0x925000 -   0x959ffb +libcurl.4.dylib ??? (???) 
<d917f9f4f8a62b86323670240e705d86> /sw/lib/libcurl.4.dylib
  0x96c000 -   0xa6dfef +libxml2.2.dylib ??? (???) 
<ef6a26eb360986920b857bc182bf7daf> /sw/lib/libxml2.2.dylib
  0xaca000 -   0xaf4feb +libssl.0.9.7.dylib ??? (???) 
<c5c933c1b5270e0a4ed4fb896f5e84ae> 
/sw/lib/libssl.0.9.7.dylib
  0xb04000 -   0xbdfffb +libcrypto.0.9.7.dylib ??? (???) 
<00bc3835907e9cfa3ee30fd0ae808413> 
/sw/lib/libcrypto.0.9.7.dylib
  0xc2f000 -   0xc6dfef +libmysqlclient.15.dylib ??? (???) 
<db92eb6ac263bf806bf8a2b676d5fee2> 
/sw/lib/mysql/libmysqlclient.15.dylib
  0xd97000 -   0xdc3fff +libxslt.1.dylib ??? (???) 
<79043201535f344e79818567e9838fab> /sw/lib/libxslt.1.dylib
  0xdd3000 -   0xdf6fea +libssh2.1.dylib ??? (???) 
/sw/lib/libssh2.1.dylib
  0xf83000 -   0xf85ffe +inclued.so ??? (???) 
<d94df3107cc2beb16f3fbc669861904b> /sw/extensions/no-debug-
non-zts-20090115/inclued.so
0x8fe00000 - 0x8fe2db43  dyld 97.1 (???) 
<100d362e03410f181a34e04e94189ae5> /usr/lib/dyld
0x90280000 - 0x903b3fff  com.apple.CoreFoundation 6.5.5 
(476.17) <4a70c8dbb582118e31412c53dc1f407f> 
/System/Library/Frameworks/CoreFoundation.framework/Versions
/A/CoreFoundation
0x903b4000 - 0x903c2ffd  libz.1.dylib ??? (???) 
<5ddd8539ae2ebfd8e7cc1c57525385c7> /usr/lib/libz.1.dylib
0x9183c000 - 0x918eeffb  libcrypto.0.9.7.dylib ??? (???) 
<69bc2457aa23f12fa7d052601d48fa29> 
/usr/lib/libcrypto.0.9.7.dylib
0x91b0b000 - 0x91b68ffb  libstdc++.6.dylib ??? (???) 
<04b812dcec670daa8b7d2852ab14be60> 
/usr/lib/libstdc++.6.dylib
0x91c7c000 - 0x91d2cfff  edu.mit.Kerberos 6.0.12 (6.0.12) 
<685cc018c133668d0d3ac6a1cb63cff9> 
/System/Library/Frameworks/Kerberos.framework/Versions/A/Ker
beros
0x91d4f000 - 0x91eb6ff3  libSystem.B.dylib ??? (???) 
<d68880dfb1f8becdbdac6928db1510fb> 
/usr/lib/libSystem.B.dylib
0x92663000 - 0x9266afe9  libgcc_s.1.dylib ??? (???) 
<f53c808e87d1184c0f9df63aef53ce0b> /usr/lib/libgcc_s.1.dylib
0x943f4000 - 0x944d4fff  libobjc.A.dylib ??? (???) 
<7b92613fdf804fd9a0a3733a0674c30b> /usr/lib/libobjc.A.dylib
0x9492d000 - 0x94951feb  libssl.0.9.7.dylib ??? (???) 
<c7359b7ab32b5f8574520746e10a41cc> 
/usr/lib/libssl.0.9.7.dylib
0x94af0000 - 0x94cbeff3  com.apple.security 5.0.4 (34102) 
<55dda7486df4e8e1d61505be16f83a1c> 
/System/Library/Frameworks/Security.framework/Versions/A/Sec
urity
0x94cbf000 - 0x94df7ff7  libicucore.A.dylib ??? (???) 
<18098dcf431603fe47ee027a60006c85> 
/usr/lib/libicucore.A.dylib
0x966ac000 - 0x966b0fff  libmathCommon.A.dylib ??? (???) 
/usr/lib/system/libmathCommon.A.dylib
0x972b7000 - 0x972e2fe7  libauto.dylib ??? (???) 
<42d8422dc23a18071869fdf7b5d8fab5> /usr/lib/libauto.dylib
0x972e3000 - 0x97301fff  libresolv.9.dylib ??? (???) 
<a8018c42930596593ddf27f7c20fe7af> 
/usr/lib/libresolv.9.dylib
0xfffe8000 - 0xfffebfff  libobjc.A.dylib ??? (???) 
/usr/lib/libobjc.A.dylib
0xffff0000 - 0xffff1780  libSystem.B.dylib ??? (???) 
/usr/lib/libSystem.B.dylib


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-21 12:16 UTC] php dot net at doppy dot nl
I'm unable to reproduce this. The supplied code simply works.
I've also done this implementation in production code.

Could be caused by OS X (as I'm on Linux), or a conflicting method between the 
parent class and the interface. Although in the latter case I would prefer a 
nice error message.
Could also been only in CVS.

---------------
PHP 5.3.10-1ubuntu2 with Suhosin-Patch (cli) (built: Mar  5 2012 18:27:21) 
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
---------------
 [2012-04-06 18:04 UTC] spam04 at pornel dot net
I can't reproduce this any more either. The bug can be closed.
 [2017-07-24 21:35 UTC] colinodell@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: colinodell
 [2017-07-24 21:35 UTC] colinodell@php.net
Closing this bug since the original submitter cannot reproduce it, nor can I reproduce it on any currently-supported version of PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue May 21 20:01:26 2019 UTC