php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58650 Error during installation: Cannot find config.m4
Submitted: 2009-04-27 05:50 UTC Modified: 2012-01-24 17:37 UTC
Votes:5
Avg. Score:4.6 ± 0.8
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:2 (40.0%)
From: tjerk dot meesters at gmail dot com Assigned: kannan
Status: Closed Package: xhprof (PECL)
PHP Version: 5.2.5 OS: RHEL4
Private report: No CVE-ID:
 [2009-04-27 05:50 UTC] tjerk dot meesters at gmail dot com
Description:
------------
When installing the extension using the PECL tool, the following error occurs:

# pecl install channel://pecl.php.net/xhprof-0.9.1
downloading xhprof-0.9.1.tgz ...
Starting to download xhprof-0.9.1.tgz (925,239 bytes)
.................done: 925,239 bytes
11 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/local/bin/phpize' in the top level source directory of the module

ERROR: `phpize' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-01 14:00 UTC] kannan@php.net
I am not too familiar with the pecl install. Looks like it expects to find config.m4 in the top-level directory (?).

In our case, the config.m4 is in the extension/ directory. Can you install it from the extension directory instead?

Try something along these lines:

% cd extension
% /usr/local/php/bin/phpize
% ./configure --with-php-config=/usr/local/php/bin/php-config
% make
% make install
 [2009-08-20 06:05 UTC] tor dot henning dot ueland at webdealhosting dot com
Confirming same bug for SLES10SP2


devel:~ # pecl install xhprof
downloading xhprof-0.9.2.tar ...
Starting to download xhprof-0.9.2.tar (Unknown size)
..........................................................done: 1,506,816 bytes
11 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

ERROR: `phpize' failed
devel:~ # phpize
Cannot find config.m4. 
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

devel:~ #
 [2009-10-15 13:58 UTC] philip at roshambo dot org
How about removing the extension/ folder (making its contents 
the root) as this seems like the standard for PECL extensions?
 [2009-10-19 05:25 UTC] pecl dot php dot net at kalexandr dot com
When I try to install xhprof with command
$ sudo pecl install channel://pecl.php.net/xhprof-0.9.2
I got:
downloading xhprof-0.9.2.tgz ...
Starting to download xhprof-0.9.2.tgz (931,660 bytes)
..........................done: 931,660 bytes
11 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

ERROR: `phpize' failed
 [2010-02-25 08:02 UTC] cweiske@php.net
Same problem on php 5.2.12 and pear 1.9.0
 [2010-07-08 02:48 UTC] h dot skwirblies at schottenland dot de
Confirmed on Debian 5.0 / PEAR 1.9.1:
----%<----
$ pecl install --force xhprof
WARNING: failed to download pecl.php.net/xhprof within preferred state "stable", will instead download version 0.9.2, stability "beta"
downloading xhprof-0.9.2.tgz ...
Starting to download xhprof-0.9.2.tgz (931,660 bytes)
.........................................................................................................................................................................................done: 931,660 bytes
11 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

ERROR: `phpize' failed
----%<----

The problem is, that PEAR cannot handle the extension subdir in the packages archive. You should move the source files and the config.m4 one dir up and edit package.xml accordingly. 

Here is a quick workaround for all that like cleanly installed extensions. Works in Debian Lenny, might work elsewhere:
----%<----
pear update-channels
pecl install --force xhprof
cd /tmp/pear/download/
cp -a xhprof-0.9.2/extension/* xhprof-0.9.2/
sed -i -r -e "s%(<file.*)extension/(.*/>)%\1\2%" package.xml 
tar czf xhprof-0.9.2.tgz package.xml xhprof-0.9.2
pecl install --force xhprof-0.9.2.tgz
----%<----
 [2010-09-28 08:33 UTC] randomuser at example dot com
The above workaround for Debian 5.0 works on Ubuntu Lucid if 
you change to the 
/build/buildd/php5-5.3.2/pear-build-download/ directory 
rather than  /tmp/pear/download
 [2010-09-29 18:31 UTC] till@php.net
Kannan's workaround works - in a nutshell:

wget http://pecl.php.net/get/xhprof-0.9.2.tgz
tar zxf xhprof-0.9.2.tgz
cd xhprof-0.9.2/extension
phpize
./configure
make
make install


... I have no idea why the package is still broken though.
 [2010-10-02 13:29 UTC] hradtke@php.net
The package is maintained at http://github.com/facebook/xhprof.  I don't think the maintainers are willing to change the structure just to fit pecl's requirements.

It will probably take an update to the pear/pecl code in order to get this extension built properly.
 [2010-10-22 14:56 UTC] peter at mapledesign dot co dot uk
In which case, should it be included in PECL if it doesn't 
work reliably? I have the same problem on Ubuntu 10.04
 [2011-08-31 03:29 UTC] kst_77 at yahoo dot com

 [2012-01-24 17:37 UTC] hradtke@php.net
The pecl installer has been fixed to allow xhprof to be installed with no work 
arounds. First upgrade pear via "pear upgrade pear" and then "pecl install 
channel://pecl.php.net/xhprof-0.9.2".
 [2012-01-24 17:37 UTC] hradtke@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Tue Apr 21 02:02:03 2015 UTC