php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #58592 Arbitrary queries support.
Submitted: 2009-03-22 03:12 UTC Modified: 2021-06-09 11:16 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: whitephoenix at mail dot ru Assigned: cmb (profile)
Status: Closed Package: memcached (PECL)
PHP Version: Irrelevant OS: all
Private report: No CVE-ID: None
 [2009-03-22 03:12 UTC] whitephoenix at mail dot ru
Description:
------------
Hello. I think it's important to support arbitrary queries in the API. Several projects extends Memcached server functionality, such as memcached-tag. For example, memcached-tag implements two new commands: tag_add and tag_delete. I think the best way to solve the problem is adding command(cmd, arg0, arg1, arg2,...) method returns an answer, and getConnection(server,port) (or getConnection(array) ) method returns pointer of connection to server.
And eventually it would be great to have such functionality (such as memcached-tag) built-in into extension.

memcached-tag - http://code.google.com/p/memcached-tag/

Thank you very much! Good luck.

Reproduce code:
---------------
$memcache->command('tag_add','mytag','myfirstkey');
$memcache->command('tag_add','mytag','mysecondkey');
$memcache->command('tag_delete','mytag');

Expected result:
----------------
Empty :)

Actual result:
--------------
Error :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-09 11:16 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2021-06-09 11:16 UTC] cmb@php.net
The memcached bug tracker is now on Github[1].  If this is still
an issue with the current memcached version, please report there.

[1] <https://github.com/php-memcached-dev/php-memcached/issues>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 12:03:37 2021 UTC