php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58570 Add dependency for e2fsprogs-devel-1.36 or higher
Submitted: 2009-03-01 23:37 UTC Modified: 2015-04-04 05:24 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: kekoav at gmail dot com Assigned: remi (profile)
Status: Closed Package: uuid (PECL)
PHP Version: 5.2.5 OS: Linux
Private report: No CVE-ID: None
 [2009-03-01 23:37 UTC] kekoav at gmail dot com
Description:
------------
The extension does not compile on a system with e2fsprogs version 1.35 or lower, the newer versions have a different uuid.h file.

When building, pecl crashes due to missing definitions of UUID_TYPE_DCE_TIME and UUID_TYPE_DCE_RANDOM.

The dependencies section should be updated to avoid confusion in the future as to why things are not working.  In browsing the uuid.h code, version 1.35(the version I have) is: http://git.kernel.org/?p=fs/ext2/e2fsprogs.git;a=blob;f=lib/uuid/uuid.h;h=5720d7f09b2e0b066c17013da8dc668e96e29ab9;hb=e55043f87678587a03895d9629efb1c5a659d392

Whereas the version it seems that this extension is looking for, 1.36 is: http://git.kernel.org/?p=fs/ext2/e2fsprogs.git;a=blob;f=lib/uuid/uuid.h;h=e9cf889aee385196868f0d4bfdbfc02c56ddeb6d;hb=674a8262e93b7db75588b2a43646c79b21599cfd

I'm not sure as to which version the extension will actually compile and link with, but it is certain e2fsprogs 1.35 and below will not work.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-02 00:31 UTC] kekoav at gmail dot com
It should be noted that version 1.0.1 of this extension does install correctly on e2fsprogs version 1.35.
 [2015-04-04 05:24 UTC] remi@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: remi
 [2015-04-04 05:24 UTC] remi@php.net
Closing as comment says version 1.0.1 is ok.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 20:01:27 2019 UTC