php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58462 Package will not compile
Submitted: 2008-12-16 20:19 UTC Modified: 2009-01-10 13:26 UTC
From: pecl at micahscomputing dot com Assigned:
Status: Closed Package: ssh2 (PECL)
PHP Version: Irrelevant OS: Ubuntu 8.10 (Intrepid)
Private report: No CVE-ID: None
 [2008-12-16 20:19 UTC] pecl at micahscomputing dot com
Description:
------------
Package will not compile.  I'm using libssh2 version 0.18.  I'm on a 64-bit system.

Reproduce code:
---------------
pecl install ssh2-beta

downloading ssh2-0.11.0.tgz ...
Starting to download ssh2-0.11.0.tgz (22,884 bytes)
........done: 22,884 bytes
5 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
 1. libssh2 prefix? : /usr

1-1, 'all', 'abort', or Enter to continue: 
building in /var/tmp/pear-build-root/ssh2-0.11.0
running: /tmp/pear/download/ssh2-0.11.0/configure --with-ssh2=/usr
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc and cc understand -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib
checking for PHP extension directory... /usr/lib/php5/20060613
checking for PHP installed headers prefix... /usr/include/php5
checking for re2c... no
configure: WARNING: You will need re2c 0.12.0 or later if you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for ssh2 support... yes, shared
checking for libssh2_banner_set in -lssh2... yes
checking for libssh2_channel_forward_listen_ex in -lssh2... yes
checking for libssh2_userauth_hostbased_fromfile_ex in -lssh2... yes
checking for libssh2_poll in -lssh2... yes
checking for libssh2_publickey_init in -lssh2... yes
checking for a sed that does not truncate output... (cached) /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating ./config.status
config.status: creating config.h
config.status: executing libtool commands
running: make
/bin/bash /var/tmp/pear-build-root/ssh2-0.11.0/libtool --mode=compile gcc  -I. -I/tmp/pear/download/ssh2-0.11.0 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/ssh2-0.11.0/include -I/var/tmp/pear-build-root/ssh2-0.11.0/main -I/tmp/pear/download/ssh2-0.11.0 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/download/ssh2-0.11.0/ssh2.c -o ssh2.lo
libtool: compile:  gcc -I. -I/tmp/pear/download/ssh2-0.11.0 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/ssh2-0.11.0/include -I/var/tmp/pear-build-root/ssh2-0.11.0/main -I/tmp/pear/download/ssh2-0.11.0 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/download/ssh2-0.11.0/ssh2.c  -fPIC -DPIC -o .libs/ssh2.o
/tmp/pear/download/ssh2-0.11.0/ssh2.c: In function ?zif_ssh2_methods_negotiated?:
/tmp/pear/download/ssh2-0.11.0/ssh2.c:503: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:504: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:508: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:509: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:510: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:511: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:516: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:517: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:518: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:519: warning: passing argument 4 of ?add_assoc_string_ex? discards qualifiers from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c: In function ?zif_ssh2_fingerprint?:
/tmp/pear/download/ssh2-0.11.0/ssh2.c:558: warning: initialization discards qualifiers from pointer target type
/bin/bash /var/tmp/pear-build-root/ssh2-0.11.0/libtool --mode=compile gcc  -I. -I/tmp/pear/download/ssh2-0.11.0 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/ssh2-0.11.0/include -I/var/tmp/pear-build-root/ssh2-0.11.0/main -I/tmp/pear/download/ssh2-0.11.0 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/download/ssh2-0.11.0/ssh2_fopen_wrappers.c -o ssh2_fopen_wrappers.lo
libtool: compile:  gcc -I. -I/tmp/pear/download/ssh2-0.11.0 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/ssh2-0.11.0/include -I/var/tmp/pear-build-root/ssh2-0.11.0/main -I/tmp/pear/download/ssh2-0.11.0 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/download/ssh2-0.11.0/ssh2_fopen_wrappers.c  -fPIC -DPIC -o .libs/ssh2_fopen_wrappers.o
/tmp/pear/download/ssh2-0.11.0/ssh2_fopen_wrappers.c: In function ?php_ssh2_channel_stream_read?:
/tmp/pear/download/ssh2-0.11.0/ssh2_fopen_wrappers.c:49: error: ?LIBSSH2_ERROR_EAGAIN? undeclared (first use in this function)
/tmp/pear/download/ssh2-0.11.0/ssh2_fopen_wrappers.c:49: error: (Each undeclared identifier is reported only once
/tmp/pear/download/ssh2-0.11.0/ssh2_fopen_wrappers.c:49: error: for each function it appears in.)
make: *** [ssh2_fopen_wrappers.lo] Error 1
ERROR: `make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-10 13:26 UTC] mikesul@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

Are you sure you were actually running libssh2 0.18? Looks like that constant was added in 0.15.

Regardless, I think using it was a bit too specific -- any return value in that function of < 0 is an error, so I've changed the code to not depend on that.
 [2009-03-27 11:35 UTC] elmer at zimtkorn dot ch
Same problem here
 [2010-01-10 05:26 UTC] eric dot marden at gmail dot com
Is there a patch available? Or is this fix in v0.11.0? Doesn't seem so, as that version still has trouble compiling:

$ make
/bin/sh /home/xentek/src/ssh2-0.11.0/libtool --mode=compile gcc  -I. -I/home/xentek/src/ssh2-0.11.0 -DPHP_ATOM_INC -I/home/xentek/src/ssh2-0.11.0/include -I/home/xentek/src/ssh2-0.11.0/main -I/home/xentek/src/ssh2-0.11.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /home/xentek/src/ssh2-0.11.0/ssh2_fopen_wrappers.c -o ssh2_fopen_wrappers.lo 
 gcc -I. -I/home/xentek/src/ssh2-0.11.0 -DPHP_ATOM_INC -I/home/xentek/src/ssh2-0.11.0/include -I/home/xentek/src/ssh2-0.11.0/main -I/home/xentek/src/ssh2-0.11.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/xentek/src/ssh2-0.11.0/ssh2_fopen_wrappers.c  -fPIC -DPIC -o .libs/ssh2_fopen_wrappers.o
/home/xentek/src/ssh2-0.11.0/ssh2_fopen_wrappers.c: In function ?php_ssh2_channel_stream_read?:
/home/xentek/src/ssh2-0.11.0/ssh2_fopen_wrappers.c:49: error: ?LIBSSH2_ERROR_EAGAIN? undeclared (first use in this function)
/home/xentek/src/ssh2-0.11.0/ssh2_fopen_wrappers.c:49: error: (Each undeclared identifier is reported only once
/home/xentek/src/ssh2-0.11.0/ssh2_fopen_wrappers.c:49: error: for each function it appears in.)
make: *** [ssh2_fopen_wrappers.lo] Error 1
 [2010-02-15 10:03 UTC] carpeneto at ieee dot org
OK, to get this working on 8.04 I had to edit the C file on 
the fly with the contents of 
http://marc.info/?l=pecl-cvs&m=123161195901499&w=2 , since I 
could not figure out how to 
download a specific build from the PECL CVS server. Worked, 
but I know there's a better way 
...
 [2010-03-21 21:34 UTC] miguelalbores at gmail dot com
The same problem here...
 [2010-04-23 15:36 UTC] g4rwin520 at gmail dot com
Hey, me too, this would be a problem, perhaps someone could tell me what to do?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 11:01:23 2020 UTC