php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58457 not compiling for Leopard's 64bit Apache
Submitted: 2008-12-13 13:04 UTC Modified: 2008-12-15 10:11 UTC
From: admin at matphot dot com Assigned:
Status: Suspended Package: imagick (PECL)
PHP Version: 5.2.5 OS: Mac OS X Leopard (10.5.5) Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: admin at matphot dot com
New email:
PHP Version: OS:

 

 [2008-12-13 13:04 UTC] admin at matphot dot com
Description:
------------
I can't seem to make imagick work on our Mac OS X Leopard 
(10.5.5) Server. By default it compiles for the 32-bit 
architecture the OS kernel is running on, but if we try to 
compile for a x86_64 build, the gcc will no longer compile the 
shared libraries essential for imagick's use in php.

After a default install (no 'build' directive), I get the 
following error:

Reproduce code:
---------------
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/php5/lib/php/extensions/no-debug-non-zts-20060613/imagick.so' - (null) in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-13 15:28 UTC] mkoppanen@php.net
Hi,

are all Imagick dependencies compiled for x86_64?
 [2008-12-14 03:26 UTC] admin at matphot dot com
Do you mean the ImageMagick base installation as well? I 
believe so - but I will check once again.

An additional note: the compiled imagick.so extension in 
Leopard doesn't have the same 'execute' icon the other 
extensions have - its icon is the same as a text file.

Thank you for your reply - I will get back to you on your 
question after verifying.
 [2008-12-14 11:49 UTC] admin at matphot dot com
Yes, I've verified and rebuilt again - imagemagick was built 
for "all" platforms by default. PHP as well is running in 
x86_64 mode.

I did notice that, by default, imagick looks to the OS for 
info about what version to compile (Leopard is i386 Darwin) 
and not the Apache that will be running the php extension - 
would this have something to do with it? Still, when I 
configure with the "build=x86_64" directive, imagick refuses 
to generate dynamic libraries (because of gcc).
 [2008-12-14 11:53 UTC] admin at matphot dot com
wait a second - that should be "i686 Darwin" and not "i386 
Darwin". I did a version check of gcc - and it was compiled 
for i686 only. Still looking...
 [2008-12-15 10:11 UTC] mkoppanen@php.net
I got a feeling that this is more of a build issue than a bug in Imagick so I am suspending the bug.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 22:03:37 2021 UTC