php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #58430 Please provide module version in phpinfo()
Submitted: 2008-11-25 06:14 UTC Modified: 2008-11-25 13:04 UTC
From: lars dot lindner at magicinternet dot de Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: 5.2.5 OS:
Private report: No CVE-ID: None
 [2008-11-25 06:14 UTC] lars dot lindner at magicinternet dot de
Description:
------------
Hello!

Right now it is hard to determine the version of memcache running in an PHP setup.

It would be nice for the module to also print the version string in the output like other modules do.

With Best Regards,
Lars Lindner

Reproduce code:
---------------
php -r 'phpinfo();' | grep -i memcache

Expected result:
----------------
$ php -r 'phpinfo();' | grep -i memcache
memcache
memcache support => enabled
memcache.allow_failover => 1 => 1
memcache.chunk_size => 32768 => 32768
memcache.default_port => 11211 => 11211
memcache.hash_function => crc32 => crc32
memcache.hash_strategy => consistent => consistent
memcache.max_failover_attempts => 20 => 20
memcache.protocol => ascii => ascii
memcache.redundancy => 1 => 1
memcache.session_redundancy => 2 => 2
$

Actual result:
--------------
$ php -r 'phpinfo();' | grep -i memcache
memcache
memcache support => enabled
memcache version => 3.0.2                  <<<<<<<<-----
memcache.allow_failover => 1 => 1
memcache.chunk_size => 32768 => 32768
memcache.default_port => 11211 => 11211
memcache.hash_function => crc32 => crc32
memcache.hash_strategy => consistent => consistent
memcache.max_failover_attempts => 20 => 20
memcache.protocol => ascii => ascii
memcache.redundancy => 1 => 1
memcache.session_redundancy => 2 => 2
$

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-25 12:57 UTC] mikael at synd dot info
sapi/cli/php -r 'phpinfo();' | grep -i -A2 memcache

> memcache support => enabled
> Version => 3.0.3-dev
> Revision => $Revision: 1.83.2.30 $

Actually, the version number has been printed since about release 3.0.1 or so
 [2008-11-25 13:04 UTC] lars dot lindner at magicinternet dot de
You are right. It's right there!!!

I incorrectly assume that it would be prefixed with "memcache".

Thanks for the help!
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 16 23:01:30 2024 UTC