php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58401 Printing in color -> pure black on same page made from mixing color ink as well
Submitted: 2008-10-30 09:15 UTC Modified: 2017-04-01 21:29 UTC
From: detlef at grunny dot demon dot nl Assigned:
Status: Wont fix Package: printer (PECL)
PHP Version: 5.1.6 OS: Windows XP Home
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2008-10-30 09:15 UTC] detlef at grunny dot demon dot nl
Description:
------------
When using php_printer on a color printer (in this case: Brother 9045CDN) printing black text only works great. But when changing the color with printer_set_option (e.g. to red), a change back to the color black ("000000") results in the printer using all 3 color toners (C, M and Y) to create the color black intead of switching back to 'black toner only'. 

On a single-page print this can be resolved by putting the change in text color after printing all black text, but on multipage prints there is no workaround possible.

Reproduce code:
---------------
// skipped: open printer handle etc.
printer_set_option($handle, PRINTER_TEXT_COLOR, "FF0000");
printer_draw_text($handle, "TEST", 0, 0);	printer_set_option($handle, PRINTER_TEXT_COLOR, "000000");
printer_draw_text($handle, "TEST", 0, 100);	
// skipped: close printer handle etc.


Expected result:
----------------
The printer should use the black toner/cartridge only after selecting black as printer text color again. 

Actual result:
--------------
The printer mixes C, M and Y toner to create black, instead of the black toner (and the black toner only), resulting in more coslty and less sharp printouts. Reproducing a similar print in Openoffice or Word results in the printer correctly using black toner only. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:29 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:29 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2010, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 01:01:23 2020 UTC