php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58383 php_printer makes php crash when paralell printer installed
Submitted: 2008-10-17 15:20 UTC Modified: 2017-04-01 21:29 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: xektrum at gmail dot com Assigned:
Status: Wont fix Package: printer (PECL)
PHP Version: 5.2.5 OS: Windows XP SP3
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2008-10-17 15:20 UTC] xektrum at gmail dot com
Description:
------------
Im using php_printer in php-gtk (php 5.2.6 nts) and all work fine untill I install a parallel printer (OKIDATA ML320 TURBO) then when I tried to print php crashes, although if i install the same printer but with emulation it works just fine. I think the error came up when I run printer_list() and the parallel printer installed.



Reproduce code:
---------------
public function Print()
  { 
    $pl = printer_list(PRINTER_ENUM_LOCAL);
    //When the printer is installed it will never show up
    //this dialog
    $dialog = new GtkDialog(
			"Seleccione una impresora",
			$this->mainWindow,
			Gtk::DIALOG_MODAL,
			array(
                          Gtk::STOCK_CANCEL,Gtk::RESPONSE_NO,
			  Gtk::STOCK_OK, Gtk::RESPONSE_OK
			     )
			);
...		

Expected result:
----------------
Array with the info of local printers

Actual result:
--------------
php crash (WINDOWS ERROR)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:29 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:29 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2010, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 00:01:24 2020 UTC