php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58352 Z_DELREF_PP and Z_ADDREF_P are 5.3 only
Submitted: 2008-09-24 19:54 UTC Modified: 2008-09-26 10:51 UTC
From: crrodriguez at suse dot de Assigned:
Status: Closed Package: hidef (PECL)
PHP Version: 5_2 CVS-2008-09-24 (dev) OS: all
Private report: No CVE-ID: None
 [2008-09-24 19:54 UTC] crrodriguez at suse dot de
Description:
------------
version 0.1.1 uses Z_DELREF_PP and Z_ADDREF_P macros that are php 5.3 only

results in

frozenarray.c:315: warning: implicit declaration of function 'Z_DELREF_PP'



frozenarray.c:389: warning: implicit declaration of function 'Z_ADDREF_P'


Reproduce code:
---------------
.-----

Expected result:
----------------
a) code fix
or
b) compile error saying that the extension requires php 5.3 or later.

Actual result:
--------------
uses undefined macros

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-09-25 12:17 UTC] gopalv82 at yahoo dot com
It built with my 5.2.x build and I checked again

http://cvs.php.net/viewvc.cgi/ZendEngine2/zend.h?revision=1.293.2.11.2.11&view=markup&pathrev=PHP_5_2#l572

seems to be in some version of 5.2 (5.2.6?) at least?
 [2008-09-25 12:56 UTC] crrodriguez at suse dot de
#define ZVAL_ADDREF(pz) (++(pz)->refcount)
#define ZVAL_DELREF(pz) (--(pz)->refcount)
#define ZVAL_REFCOUNT(pz) ((pz)->refcount) 

are the ones defined there ;) there is no Z_DELREF_PP and Z_ADDREF_P

cristian@xpsm1330:~/php5.2> grep Z_ADDREF_P Zend/*.h
cristian@xpsm1330:~/php5.2>
 [2008-09-26 10:51 UTC] gopalv82 at yahoo dot com
anyway :)

http://news.php.net/php.pecl.cvs/11384
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 04:01:27 2019 UTC