php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #58339 Multiple-feature/fix patch
Submitted: 2008-09-10 06:12 UTC Modified: 2008-10-21 18:45 UTC
From: jdw at wheelhouse dot org Assigned:
Status: Closed Package: spread (PECL)
PHP Version: 5.2.5 OS: FreeBSD
Private report: No CVE-ID: None
 [2008-09-10 06:12 UTC] jdw at wheelhouse dot org
Description:
------------
I've prepared a patch against version 2.0.2 of the spread 
module with the following changes:

* Added missing spread_leave() function.
* Support for optional stype parsing.
* Support for optional group membership messages.
* Fixed a comment typo.
* Change spread_receive() to return null on timeout and false 
on error

It would be great if some or all of this patch could be rolled 
into the next release of the module.





Reproduce code:
---------------
http://software.wheelhouse.org/php_spread/

Expected result:
----------------
n/a

Actual result:
--------------
n/a

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-21 13:08 UTC] rrichards@php.net
Appears most of these changes were implemented starting around the June timeframe. stype parsing will not be implemented as stype code is already available.
 [2008-10-21 13:19 UTC] jdw at wheelhouse dot org
The June release (2.0.2) you refer to was the most recent at the time of the patch (September) and does not implement any of these fixes/changes.  That's why this patch is against that version.

These changes are nontrivial, they are not already implemented and they are absolutely necessary for complete/correct use of Spread.
 [2008-10-21 13:23 UTC] rrichards@php.net
They are in CVS though haven't yet been released
 [2008-10-21 13:29 UTC] jdw at wheelhouse dot org
Then please release a version containing these fixes before you write off legitimate problems with the current release version and the hard work to fix them independently as "bogus."
 [2008-10-21 13:40 UTC] rrichards@php.net
Sorry that our bug system offends you, but as the 
functionality has already been implemented, this bug ends up 
with a status of Bogus. We really do appreciate the work 
that you put into the code, but we have no control over the 
Status message the bug system uses here.

Please leave this closed because there is no open bug here. 
I am looking into making a release with all the latest 
additions.
 [2008-10-21 14:08 UTC] jdw at wheelhouse dot org
Likewise, I am sorry that PECL doesn't have a good enough track record in this area to let you write off issues just because they are fixed in CVS.  The php4 SQLite PECL module, for example, has bugs that have been "fixed in CVS" for over 4 years.  This may be why "fixed in CVS" is not a status option.

If I'm "offended," it's because I've just found out (somewhat rudely) that I wasted a whole lot of time re-fixing bugs that were already fixed because the fixes were neither released nor documented for months.

The bugs exist in the current release, and deserve to be documented (and documented as fixed), if only so that you don't waste anyone else's time.  If you want the bug report to go away and stay away, please spend your effort releasing the fixes, rather than sweeping problem documentation under the rug.
 [2008-10-21 14:17 UTC] rrichards@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 [2008-10-21 14:29 UTC] pierre dot php at gmail dot com
It is a common usage to first check the CVS/SVN/GIT status before trying to fix a bug in a release. VCS is where the development is done, a release is only the last step of a development phase, no need to be offended for that :)
 [2008-10-21 14:36 UTC] jdw at wheelhouse dot org
I looked extensively for a public source code repository for this module before I did anything.  If there is one, it's not linked from anywhere on the module's page.

But don't worry about me, I won't make the same mistake again.
 [2008-10-21 18:13 UTC] hannes dot magnusson at gmail dot com
http://pecl.php.net/package/spread
Click "browse source".
For more info about php.net CVS see http://php.net/anoncvs

-Hannes
 [2008-10-21 18:45 UTC] jdw at wheelhouse dot org
Thanks for your suggestion Hannes, but that only works if the "Browse Source" link is enabled, which it was not.

It was enabled by rrichards today in response to my previous message.  Hopefully that will benefit people who have future questions about the status of this module, so maybe they don't have to wind up like me. :-)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 14:01:23 2020 UTC