php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58334 bcompiler segfaults on easy code
Submitted: 2008-09-05 09:47 UTC Modified: 2011-09-02 03:34 UTC
From: marco at harddisk dot is-a-geek dot org Assigned:
Status: Closed Package: bcompiler (PECL)
PHP Version: 5.2.5 OS: Win XP SP2 (Cygwin)
Private report: No CVE-ID: None
 [2008-09-05 09:47 UTC] marco at harddisk dot is-a-geek dot org
Description:
------------
bcompiler crashes on compiling five lines of easy code.

$ php runbomb.php
      8 [main] php 7072 _cygtls::handle_exceptions: Error while dumping state (probably corrupted stack)
Segmentation fault (core dumped)



Reproduce code:
---------------
bomb.php:
<?PHP
function debug($level,$message,$component=0) { 
}

function callback() {
}
?>
runbomb.php:
<?PHP
$fh = fopen("bomb.phb", "w");
bcompiler_write_header($fh);
bcompiler_write_file($fh, "bomb.php");
bcompiler_write_footer($fh);
fclose($fh);
?>


Expected result:
----------------
bcompiler compiles bomb.php

Actual result:
--------------
$ cat php.exe.stackdump
Exception: STATUS_ACCESS_VIOLATION at eip=69847462
eax=00000000 ebx=0022B4E8 ecx=100F0688 edx=00000000 esi=0022B4EC edi=0022B4F0
ebp=0022B548 esp=0022B4C0 program=C:\cygwin\bin\php.exe, pid 7072, thread main
cs=001B ds=0023 es=0023 fs=003B gs=0000 ss=0023
Stack trace:
Frame     Function  Args
0022B548  69847462  (00000002, 7FF70558, 00000000, 00000000)
0022B5D8  65D814CE  (0022B6C0, 10010000, 00000007, 7C91D592)
0022B708  65D80BA8  (7FF6FDE8, 7FF6DBD8, 00000051, 0022B748)
0022B758  65D63CAE  (00000008, 00000000, 00000003, 00000000)
0022C9F8  65D22C56  (0022CC90, 00000007, 00405180, 00407020)
0022CCE8  00402801  (00000002, 6116B6F0, 10010090, 00000000)
0022CD98  610060D8  (00000000, 0022CDD0, 61005450, 0022CDD0)
61005450  61004416  (0000009C, A02404C7, E8611021, FFFFFF48)
      8 [main] php 7072 _cygtls::handle_exceptions: Error while dumping state (probably corrupted stack)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-02 03:19 UTC] zhihong dot chen dot cn at gmail dot com
This could be safely closed.
This bug could not reproduced on both 5.3.6 and 5.3.8 with 
bcompiler 1.02
 [2011-09-02 03:34 UTC] alan at akbkhome dot com
as per comment
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 20:03:41 2021 UTC