php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58320 Backwards compatibility issues
Submitted: 2008-08-19 11:44 UTC Modified: 2008-08-20 18:00 UTC
From: jani@php.net Assigned:
Status: Not a bug Package: bbcode (PECL)
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
 [2008-08-19 11:44 UTC] jani@php.net
Description:
------------
Basically nothing works. Only smileys seem to work with 1.0.2. All code worked fine with 1.0.0.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-19 12:17 UTC] xdecock at gmail dot com
All test cases were OK on both 32 & 64 bit (5.2 and 5.3 was tested), can you give me a basic example of what worked on 1.0.0 and is not more working in 1.0.2?

Thanks.
 [2008-08-19 12:52 UTC] xdecock at gmail dot com
Are you using the bbcode_set_flags function?

On 1.0.0 it was not working on 64 bit (the main cause of the buggy correction of 1.0.1) and it was corrected in 1.0.2 and so the flags can now be effectively changed, and so a proper use of bbcode_set_flags is needed are you using BBCODE_SET_FLAGS_ADD or BBCODE_SET_FLAGS_SET as third option to this function? the default behaviour is to remove all flags and set only the given flagset.
 [2008-08-20 18:00 UTC] jani@php.net
This seems to have got fixed by sun spots or something since I can't reproduce it anymore.. :)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 21:03:38 2021 UTC