php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58306 Invalid search path
Submitted: 2008-08-10 10:46 UTC Modified: 2008-08-10 17:32 UTC
From: classicmanpro at yahoo dot com Assigned:
Status: Not a bug Package: imagick (PECL)
PHP Version: 5.2.5 OS: NetBSD/i386 4.0
Private report: No CVE-ID: None
 [2008-08-10 10:46 UTC] classicmanpro at yahoo dot com
Description:
------------
On NetBSD/i386 4.0 the './configure' script fails due to 
the fact that 'Wand-config' is in a different location.

I found that at line 3900 and 3907 './configure' was 
looking only in '/usr/local' and '/usr' but:

% which Wand-config
/usr/pkg/bin/Wand-config

I had to append ' /usr/pkg' at the end of the search list 
and './configure' worked.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-10 13:27 UTC] mkoppanen@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.


Did you try --with-imagick=/usr/pkg ?
 [2008-08-10 14:59 UTC] classicmanpro at yahoo dot com
Description:
------------
On NetBSD/i386 4.0 the './configure' script fails due to 
the fact that 'Wand-config' is in a different location.


Reproduce code:
---------------
% cd ~/src/imagick-2.2.0
% phpize
% ./configure
% make
% make install


Expected result:
----------------
Build and Install iMagick.


Actual result:
--------------
'./configure' script fails and reports that it's unable to locate 'Wand-config':

... not found. Please provide a path to MagickWand-config or Wand-config program.


Possible solution:
------------------
Either specify in the INSTALL file that --with-imagick should be used on *BSD systems or edit the 'config.m4' at line 15 and at line 22 and append '/usr/pkg' to the 'for' search list.

PS: I've tested the 'config.m4' solution and it worked perfectly.
 [2008-08-10 17:32 UTC] mkoppanen@php.net
Thank you for taking the time to write to us, but this is not
a bug.

./configure --help provides the following information:

 --with-imagick=DIR     Enables the imagick extension. DIR is the prefix to Imagemagick installation directory.

In your case ImageMagick installation directory seems to be /usr/pkg.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Aug 11 01:01:25 2020 UTC