php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58293 Missing .dsp file
Submitted: 2008-07-28 18:08 UTC Modified: 2015-03-29 22:59 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: pokusovac at seznam dot cz Assigned: kalle (profile)
Status: Closed Package: intl (PECL)
PHP Version: 5.2.5 OS: Windows XP
Private report: No CVE-ID: None
 [2008-07-28 18:08 UTC] pokusovac at seznam dot cz
Description:
------------
Hello,

I have problem with installing intl package.

I first run pear install, but it didn't work, it said to use pecl.
So I did. The package is downloaded, but then it failes. I didn't find any answer on net.


C:\dev_tools\php\5.2.5>pecl install intl
downloading intl-1.0.0.tgz ...
Starting to download intl-1.0.0.tgz (130,386 bytes)
.............................done: 130,386 bytes
89 source files, building
ERROR: The DSP intl.dsp does not exist.

Can you help me? I really don't know, what to do.
Thanks a lot

I already sent email to stas AT zend ... but no answer. :/
I'm trying this way...



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-28 18:50 UTC] stas at zend dot com
Hm... I'm not familiar with how PECL installs on Windows, so I should check that.
But in the meantime it's easy to build it this way:

1. Download the source package
2. Put it into ext/intl
3. Run buildconf
4. Eun configure with --enable-intl=shared added to regular options
5. Run nmake

This should build working .dll in your target directory. I built it this way. Please tell me if there's a problem with that.

P.S. Don't know why I didn't get your email. May be spam filter acting up? Sorry for that.
You''
 [2008-08-25 19:24 UTC] stas at zend dot com
Looks like PECL builds for windows never really worked properly, so it's best to take it from snaps or build inside the source tree...
 [2015-03-29 22:59 UTC] kalle@php.net
-Status: Suspended +Status: Closed -Assigned To: +Assigned To: kalle
 [2015-03-29 22:59 UTC] kalle@php.net
We don't support DSP files anymore, and haven't for many years so closing this
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 04:01:23 2020 UTC