php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58276 configure problem
Submitted: 2008-07-16 14:53 UTC Modified: 2008-07-21 15:36 UTC
From: istvanp at gmail dot com Assigned:
Status: Closed Package: svn (PECL)
PHP Version: 5.2.6 OS: Fedora Core 8
Private report: No CVE-ID:
 [2008-07-16 14:53 UTC] istvanp at gmail dot com
Description:
------------
PEAR Version: 1.6.2
PHP Version: 5.2.6
PHP Configure: './configure' '--build=i386-redhat-linux-gnu' '--host=i386-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--without-mime-magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-system-tzdata' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter' '--disable-json'
Zend Engine Version: 2.2.0
Running on: Linux 2.6.24.4-64.fc8 #1 SMP Sat Mar 29 09:54:46 EDT 2008 i686
---------------
Installing pecl package 'svn-beta' from the command line gives the following error:
# /tmp/pear/download/svn-0.4.1/configure --with-svn-apr=/usr/local/apr
...
...
checking for svn libraries... -lsvn_client-1 -lsvn_fs-1 -lsvn_repos-1 -lsvn_subr-1  -L/usr/local/apr/lib -lapr-1
checking for svn_client_move3 in -lsvn_client-1... no
/tmp/pear/download/svn-0.4.1/configure: line 4158: unset: `ac_cv_lib_svn_client-1_svn_client_move3': not a valid identifier
configure: error: failed to determine svn version or less than 1.3


SVN is installed and working however and I have 2 versions available 1.4.4 and the default is 1.5.0.
# which svn
/usr/local/bin/svn
# svn --version --quiet
1.5.0

Reproduce code:
---------------
pecl install svn-beta

Expected result:
----------------
svn pecl package installs successfully.

Actual result:
--------------
svn pecl package cannot be installed because of an error.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-16 14:56 UTC] scottmac@php.net
Do you have svn-devel installed?
 [2008-07-16 15:01 UTC] istvanp at gmail dot com
Not that I know of, no.
 [2008-07-16 15:06 UTC] scottmac@php.net
Well install subversion-devel again via yum and give it a go.

If that fixes it let me know and I'll look into adjusting the 
configure script.
 [2008-07-16 15:22 UTC] istvanp at gmail dot com
Still no luck.
A question though. The script could not find my apr-1-config and I had to specify it (its in /usr/local/apr/bin). What about svn? Even if I specify the 2 locations I have the bins (one of each version: 1.4.4 in /usr/bin and 1.5.0 in /usr/local/bin) it stops at the same error. Is this a legitimate error about identifying the version or is it more of a catch all error? I might have a "1.6.0 dev build" lurking somewhere in my server I had installed in April and was wondering if it that is what is causing it.
 [2008-07-17 17:49 UTC] scottmac@php.net
Can you try the config.m4 from cvs, there is a better version check performed within it.

http://cvs.php.net/viewvc.cgi/pecl/svn/config.m4?view=log
 [2008-07-18 09:41 UTC] istvanp at gmail dot com
Still the same error. I checked the config log and there are 96 undefined references for neon:

...
configure:4120: gcc -o conftest -g -O2  -Wl,-rpath,/usr/local/lib -L/usr/local/lib  conftest.c -lsvn_client-1   >&5
/usr/local/lib/libsvn_ra_neon-1.so.0: undefined reference to `X509_NAME_entry_count'
...
/usr/local/lib/libsvn_ra_neon-1.so.0: undefined reference to `X509_STORE_add_cert'
/usr/local/lib/libsvn_ra_neon-1.so.0: undefined reference to `SSLeay'
/usr/local/lib/libsvn_ra_neon-1.so.0: undefined reference to `SSL_get_peer_cert_chain'
collect2: ld returned 1 exit status
configure:4126: $? = 1
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| /* end confdefs.h.  */
| 
| /* Override any GCC internal prototype to avoid an error.
|    Use char because int might match the return type of a GCC
|    builtin and then its argument prototype would still apply.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| char svn_client_move3 ();
| int
| main ()
| {
| return svn_client_move3 ();
|   ;
|   return 0;
| }
configure:4144: result: no
configure:4167: error: failed to determine svn version or less than 1.3
...

Might neon be the cause?
 [2008-07-18 10:04 UTC] scottmac@php.net
It looks related to SSL.

Can you use ldd to check to see if libsvn_ra_neon-1.so is linked against an ssl library.

I checked on my 1.4 and I see that libsvn_ra_dav-1.so was linked against libssl.
 [2008-07-18 10:44 UTC] istvanp at gmail dot com
[root@demoserv ~]# ldd /usr/lib/libsvn_ra_neon-1.so
        linux-gate.so.1 =>  (0x00110000)
        libsvn_delta-1.so.0 => /usr/local/lib/libsvn_delta-1.so.0 (0x0014c000)
        libsvn_subr-1.so.0 => /usr/local/lib/libsvn_subr-1.so.0 (0x00156000)
        libaprutil-1.so.0 => /usr/local/apr/lib/libaprutil-1.so.0 (0x0019a000)
        libexpat.so.1 => /lib/libexpat.so.1 (0x001b6000)
        libapr-1.so.0 => /usr/local/apr/lib/libapr-1.so.0 (0x001d7000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x001fc000)
        librt.so.1 => /lib/librt.so.1 (0x00200000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00250000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00209000)
        libdl.so.2 => /lib/libdl.so.2 (0x00222000)
        libc.so.6 => /lib/libc.so.6 (0x00282000)
        /lib/ld-linux.so.2 (0x00233000)
[root@demoserv ~]# ldd /usr/local/lib/libsvn_ra_neon-1.so
        linux-gate.so.1 =>  (0x00110000)
        libsvn_delta-1.so.0 => /usr/local/lib/libsvn_delta-1.so.0 (0x0014c000)
        libsvn_subr-1.so.0 => /usr/local/lib/libsvn_subr-1.so.0 (0x00156000)
        libaprutil-1.so.0 => /usr/local/apr/lib/libaprutil-1.so.0 (0x0019a000)
        libexpat.so.1 => /lib/libexpat.so.1 (0x001b6000)
        libapr-1.so.0 => /usr/local/apr/lib/libapr-1.so.0 (0x001d7000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x001fc000)
        librt.so.1 => /lib/librt.so.1 (0x00200000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00250000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00209000)
        libdl.so.2 => /lib/libdl.so.2 (0x00222000)
        libc.so.6 => /lib/libc.so.6 (0x00282000)
        /lib/ld-linux.so.2 (0x00233000)

Strange, I had compiled with the openssl option. I'll try to recompile neon to double check.
 [2008-07-21 15:36 UTC] istvanp at gmail dot com
I had to clean before rebuilding the package with the new version check and it worked this time. The first time I tried the new config.m4 I probably didn't clean.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 05:03:21 2014 UTC