php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58258 Don't ask for 'instantclient' during install/upgrade
Submitted: 2008-06-30 15:16 UTC Modified: 2009-03-12 18:54 UTC
From: gena01 at gmail dot com Assigned:
Status: Closed Package: oci8 (PECL)
PHP Version: 5.2.4 OS: Linux
Private report: No CVE-ID:
 [2008-06-30 15:16 UTC] gena01 at gmail dot com
Description:
------------
So I just did a pear upgrade pecl/oci8
and got:
 1. Please provide the path to the ORACLE_HOME directory. Use 'instantclient,/path/to/instant/client/lib' if you're compiling with Oracle Instant Client : autodetect

I tried to just hit enter and have it "autodetect" and I got an error message:
checking OCI8 libraries dir... lib
checking Oracle version... configure: error: Oracle client libraries not found

However if I select '1' and enter 'instantclient' and then hit enter then everything works. 

Reproduce code:
---------------
1. pear upgrade pecl/oci8
2. Hit enter at the prompt.


Expected result:
----------------
Compiles and works. 

Actual result:
--------------
checking OCI8 libraries dir... lib
checking Oracle version... configure: error: Oracle client libraries not found


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-01 03:17 UTC] tony at daylessday dot org
You can have both instant and "old" client installed, so you have to choose which version OCI8 configure should be looking for.
No bug here.
 [2008-07-01 06:46 UTC] gena01 at gmail dot com
I don't have a problem with the old client being installed. I'd rather see configure automatically look for instant client if old client is not there instead of throwing an error message to the screen.
 [2008-07-01 06:50 UTC] tony at daylessday dot org
We do accept patches for features you want to see in future releases.
Still no bug here.
 [2008-07-30 15:36 UTC] gena01 at gmail dot com
Ok. I just whipped up a quick patch. Re-opening as a feature request.
 [2008-07-30 15:39 UTC] gena01 at gmail dot com
Sorry for the spam, but it seems that I can't add attachment(s) here.

Here is the link to the patch: http://pastebin.com/f50771791
 [2009-03-12 18:54 UTC] christopher dot jones at oracle dot com
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

Fixed in PHP 5.3 and 6.  Will also be in the (future) PECL OCI8 1.3.5.

This enhancement also benefits full PHP builds.  If ./configure --with-oci8 or --with-oci8=shared is specified but the ORACLE_HOME environment variable is not actually set, the install will warn and look for the Instant Client RPM.

Patched file (which was also refactored) is at http://cvs.php.net/viewvc.cgi/pecl/oci8/config.m4?r1=1.55.2.3.2.11.2.6&r2=1.55.2.3.2.11.2.7
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 18:01:55 2014 UTC