php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58185 compile error
Submitted: 2008-05-01 15:58 UTC Modified: 2012-05-25 13:01 UTC
From: sniemetz at gmail dot com Assigned:
Status: Not a bug Package: mqseries (PECL)
PHP Version: 4.3.8 OS: linux
Private report: No CVE-ID: None
 [2008-05-01 15:58 UTC] sniemetz at gmail dot com
Description:
------------
I run 

% LDFLAGS="-L/opt/mqm/maintenance/6.0.2.3/MQSeriesSDK/opt/mqm/lib -L/opt/mqm/maintenance/6.0.2.3/MQSeriesRuntime/opt/mqm/lib -L/opt/mqm/maintenance/6.0.2.3/MQSeriesClient/opt/mqm/lib" ./configure

% ./make


Reproduce code:
---------------
line 99:
ZEND_BEGIN_ARG_INFO_EX(arginfo_mqseries_back,0,0,3)
        ZEND_ARG_INFO(0, hconn)
        ZEND_ARG_INFO(1, compCode)
        ZEND_ARG_INFO(1, reason)
ZEND_END_ARG_INFO()

line 106:
ZEND_BEGIN_ARG_INFO_EX(arginfo_mqseries_begin,0,0, 4)
        ZEND_ARG_INFO(0, hconn)
        ZEND_ARG_INFO(0, beginOptions)
        ZEND_ARG_INFO(1, compCode)
        ZEND_ARG_INFO(1, reason)
ZEND_END_ARG_INFO()

line 254:
zend_module_entry mqseries_module_entry = {
#if ZEND_MODULE_API_NO >= 20010901
        STANDARD_MODULE_HEADER,
#endif



Expected result:
----------------
error-free compilation

Actual result:
--------------
/bin/sh /a1/downloads/mq/mqseries-0.11.0/libtool --mode=compile gcc  -I. -I/a1/downloads/mq/mqseries-0.11.0 -DPHP_ATOM_INC -I/a1/downloads/mq/mqseries-0.11.0/include -I/a1/downloads/mq/mqseries-0.11.0/main -I/a1/downloads/mq/mqseries-0.11.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/opt/mqm/maintenance/6.0.2.3/MQSeriesSDK/opt/mqm/inc  -DHAVE_CONFIG_H  -g -O2  -prefer-pic -c /a1/downloads/mq/mqseries-0.11.0/mqseries.c -o mqseries.lo
 gcc -I. -I/a1/downloads/mq/mqseries-0.11.0 -DPHP_ATOM_INC -I/a1/downloads/mq/mqseries-0.11.0/include -I/a1/downloads/mq/mqseries-0.11.0/main -I/a1/downloads/mq/mqseries-0.11.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/opt/mqm/maintenance/6.0.2.3/MQSeriesSDK/opt/mqm/inc -DHAVE_CONFIG_H -g -O2 -c /a1/downloads/mq/mqseries-0.11.0/mqseries.c  -fPIC -DPIC -o .libs/mqseries.o
/a1/downloads/mq/mqseries-0.11.0/mqseries.c:99: error: syntax error before numeric constant
/a1/downloads/mq/mqseries-0.11.0/mqseries.c: In function `ZEND_END_ARG_INFO':
/a1/downloads/mq/mqseries-0.11.0/mqseries.c:106: error: syntax error before numeric constant
/a1/downloads/mq/mqseries-0.11.0/mqseries.c:107: error: storage class specified for parameter `ZEND_BEGIN_ARG_INFO_EX'
/a1/downloads/mq/mqseries-0.11.0/mqseries.c:254: error: parameter `mqseries_module_entry' is initialized
/a1/downloads/mq/mqseries-0.11.0/mqseries.c:259: error: `mqseries_functions' undeclared (first use in this function)
/a1/downloads/mq/mqseries-0.11.0/mqseries.c:259: error: (Each undeclared identifier is reported only once
/a1/downloads/mq/mqseries-0.11.0/mqseries.c:259: error: for each function it appears in.)
/a1/downloads/mq/mqseries-0.11.0/mqseries.c:259: confused by earlier errors, bailing out
make: *** [mqseries.lo] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-25 13:01 UTC] pierrick@php.net
-Status: Open +Status: Not a bug
 [2012-05-25 13:01 UTC] pierrick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 07:01:23 2020 UTC