php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58101 phpize fails if XMS not present
Submitted: 2008-03-14 05:54 UTC Modified: 2017-04-01 21:35 UTC
Votes:4
Avg. Score:4.2 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (33.3%)
From: mfp@php.net Assigned:
Status: Wont fix Package: sam (PECL)
PHP Version: 5.2.1 OS: RHEL Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2008-03-14 05:54 UTC] mfp@php.net
Description:
------------
"pecl install sam" does not work - it fails in the phpize step with a complaint about XMS. Yet when I read the install instructions it says XMS is optional. 

Reproduce code:
---------------
pecl install sam



Actual result:
--------------
downloading SAM-1.1.0.tgz ...
Starting to download SAM-1.1.0.tgz (43,788 bytes)
............done: 43,788 bytes
13 source files, building
running: phpize

.../...

checking for sam support... yes, shared
checking for sam xms support... yes, shared
checking for sam xms files in default path... not found
configure: error: Please reinstall the XMS distribution
ERROR: `/tmp/pear/cache/SAM-1.1.0/configure' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-17 11:18 UTC] andypiperuk at gmail dot com
I can confirm that the same thing occurs on Ubuntu Intrepid (8.10) and PHP 5

I've tried running /tmp/pear/download/SAM-1.1.0/configure --with-sam_xms=NO (and --without-sam_xms) with the same results.
 [2017-04-01 21:35 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:35 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2007, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 11:03:34 2021 UTC