php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58059 Issues with writeImage and cropThumbnailImage
Submitted: 2008-02-24 20:50 UTC Modified: 2008-02-25 15:31 UTC
From: datafirm at mac dot com Assigned:
Status: Not a bug Package: imagick (PECL)
PHP Version: 5.2.1 OS: FreeBSD 6.1
Private report: No CVE-ID: None
 [2008-02-24 20:50 UTC] datafirm at mac dot com
Description:
------------
I am getting the same results. I have an input image of 70?73 
and when I cropThumbnailImage(300, 300) the getImageGeometry() 
shows correctly, but the saved image is incorrect at 300?312.
I am running on the latest CVS build. Any ideas?

see post here: http://valokuva.org/?p=8#comment-1290

Expected result:
----------------
a cropped image saved to disc with dimensions of 300x300


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-02-25 04:20 UTC] mkoppanen@php.net
Thank you for taking the time to write to us, but this is not
a bug.

Seems to be related to virtual canvas. Call setImagePage( 300, 300, 0, 0); after cropthumbnailimage.
 [2008-02-25 15:14 UTC] datafirm at mac dot com
I tried this and still get the same results.
 [2008-02-25 15:26 UTC] mkoppanen@php.net
$ php -r '$im = new Imagick(); $im->newImage( 70, 73, "white" ); $im->cropThumbnailImage( 300, 300 ); $im->writeImage( "test.jpg" );' && identify test.jpg
test.jpg JPEG 300x300 300x300+0+0 PseudoClass 256c 8-bit 522b


I am unable to reproduce this issue.
 [2008-02-25 15:31 UTC] datafirm at mac dot com
please disregard.  Thanks for the suggestion.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 19:01:23 2020 UTC