php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58037 ERROR: Did not understand the completion status returned from msdev.exe
Submitted: 2008-02-10 15:09 UTC Modified: 2011-02-10 18:56 UTC
From: ahicham26 at yahoo dot fr Assigned:
Status: Wont fix Package: bcompiler (PECL)
PHP Version: 4.3.10 OS: windows xp sp2
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2008-02-10 15:09 UTC] ahicham26 at yahoo dot fr
Description:
------------
downloading bcompiler-0.8.tgz ...
Starting to download bcompiler-0.8.tgz (46,667 bytes)
..........
...done: 46,667 bytes
10 source files, building
running: msdev bcompiler.dsp /MAKE "bcompiler - Release"
ERROR: Did not understand the completion status returned from msdev.exe.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-28 17:40 UTC] adam dot hughes at questtech dot co dot uk
I'm running php 5.2.5 on windows 2003 server and I get the same error (displayed below)

C:\php>pecl install apc
downloading APC-3.0.18.tgz ...
Starting to download APC-3.0.18.tgz (115,957 bytes)
.........................done: 115,957 bytes
47 source files, building
running: msdev APC.dsp /MAKE "APC - Release"
ERROR: Did not understand the completion status returned from msdev.exe.

C:\php>
 [2008-05-06 05:24 UTC] moloud dot shahbazi at gmail dot com
I faced the same problem. what should I do to fix this problem?
 [2008-05-08 06:51 UTC] maik at finsterbusch dot net
the same for me. ill try to setup an virtual machine running debian now. damn.
 [2008-06-16 18:25 UTC] asmiley at livemocha dot com
Reproed with PHP 5.2.6, pear 1.7.1 on Windows XP Pro.
 [2008-06-30 06:40 UTC] aniruddha dot shival at gmail dot com
I'm running php 5.1.4 on windows 2000 and I'm getting above mentioned error message while installing xdebug library through pecl.

I'm executing following command

C:\Program Files\xampp\php>pecl install xdebug
WARNING: channel "pecl.php.net" has updated its protocols, use "channel-update p
ecl.php.net" to update
downloading xdebug-2.0.3.tgz ...
Starting to download xdebug-2.0.3.tgz (286,325 bytes)
........done: 286,325 bytes
66 source files, building
running: msdev xdebug.dsp /MAKE "xdebug - Release"
ERROR: Did not understand the completion status returned from msdev.exe.

I need to install debug for code coverage analysis. Please help.
 [2008-11-20 18:10 UTC] jma at oksofar dot com
I got this problem, so I entered "msdev" on the command line. It was not found in the path. 

So this error really seems to be "msdev not found".

Does anyone know what msdev is and how to get it (or where it is?).
 [2009-04-12 17:00 UTC] jack at thewizardrie dot com
msdev is part of older versions of Visual Studio, and can't even be installed with newer versions. PECL should remove reliance on this program since 1) many people don't have or want to have Visual Studio, and 2) it's deprecated.

I need to install Xdebug on Windows XP and wish it were possible using PEAR/PECL!

For now though you can just download the binary from http://www.xdebug.org/download.php, put it in your Program Files\PHP\ext directory (or wherever), and then in php.ini, add:

zend_extension_ts="C:/Program Files/PHP/ext/php_xdebug-2.0.4-5.2.8.dll"
 [2009-12-04 12:44 UTC] val@php.net
Sorry, it's really not a bcompiler bug. It should be fixed in PECL installer, if hasn't already fixed.
 [2010-08-04 05:53 UTC] remi dot denoyelle2 at gmail dot com
Same problem with command
 pecl install bcompiler-0.9.3

any news ?
 [2010-10-09 14:24 UTC] wertygol at gmail dot com
I have the same problem installing APC

C:\PHP>pecl install apc
downloading APC-3.0.19.tgz ...
Starting to download APC-3.0.19.tgz (115,735 bytes)
.........done: 115,735 bytes
47 source files, building
WARNING: php_bin .\php.exe appears to have a suffix .exe, 
but config variable ph
p_suffix does not match
running: msdev APC.dsp /MAKE "APC - Release"
ERROR: Did not understand the completion status returned 
from msdev.exe.
 [2011-02-10 09:21 UTC] sirber at detritus dot qc dot ca
same thinf on "pecl.bat install odbtp"

msdev.exe not found
 [2011-02-10 18:56 UTC] alan at akbkhome dot com
IMPORTANT - READ THIS

This bug is related to pear/pecl if you wish to help fix it.

a) report it here
http://pear.php.net/bugs/report.php?package=PEAR

b) reply to any queries about it.


REMEMBER POSTING "ME TO" HERE IS A COMPLETE WASTE OF YOUR 
TIME..
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Feb 23 16:01:26 2019 UTC