php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58035 undefined symbols during linking
Submitted: 2008-02-10 00:35 UTC Modified: 2008-03-28 11:24 UTC
From: yselkowitz at users dot sourceforge dot net Assigned:
Status: Closed Package: svn (PECL)
PHP Version: 5.2.1 OS: Cygwin
Private report: No CVE-ID: None
 [2008-02-10 00:35 UTC] yselkowitz at users dot sourceforge dot net
Description:
------------
The svn.la module requires several of the libsvn_*-1 libraries, not just svn_client.  On Cygwin, building svn-0.3 fails due to undefined symbols during linking.  Patch below.

Reproduce code:
---------------
--- origsrc/svn-0.3/config.m4   2008-02-09 08:39:10.000000000 -0600
+++ src/svn-0.3/config.m4   2008-02-09 22:53:41.812500000 -0600
@@ -21,7 +21,7 @@
            if test -d $i/lib64 ; then
            PHP_SVN_LDFLAGS="-L$i/lib64"
            fi
-           PHP_SVN_LDFLAGS="-lsvn_client-1"
+           PHP_SVN_LDFLAGS="-lsvn_client-1 -lsvn_fs-1 -lsvn_repos-1 -lsvn_subr-1"
            break;
        fi
    done



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-02-10 20:45 UTC] scottmac@php.net
What's the exact error message?

I can't reproduce this on OS X with gcc 4.01, it links fine here and I can test without issue.
 [2008-03-28 11:24 UTC] scottmac@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Apr 24 01:01:25 2019 UTC