php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58031 pecl install on Windows fails
Submitted: 2008-02-06 10:24 UTC Modified: 2019-10-20 16:13 UTC
Votes:6
Avg. Score:4.3 ± 0.7
Reproduced:5 of 5 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (40.0%)
From: myteamz at rogers dot com Assigned: cmb (profile)
Status: Not a bug Package: stats (PECL)
PHP Version: 5.2.1 OS: Windows XP Pro
Private report: No CVE-ID: None
 [2008-02-06 10:24 UTC] myteamz at rogers dot com
Description:
------------
When trying to install the package stats with the command

pecl install stats

I get the message: The DSP stats.dsp does not exist.

I am using the current version (1.7.1) of PEAR

Reproduce code:
---------------
pecl install stats


Expected result:
----------------
successful install of stats package

Actual result:
--------------
downloading stats-1.0.2.tgz ...
Starting to download stats-1.0.2.tgz (99,018 bytes)
......................done: 99,018 bytes
17 source files, building
ERROR: The DSP stats.dsp does not exist.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-14 13:53 UTC] dolgov at bk dot ru
Reproduced:

OS: Windows 7 Enterprise x64
PHP: 5.3.13

C:\Program Files (x86)\PHP\PEAR>pecl install -f http://pecl.php.net/get/stats-
1.0.2.tgz
downloading stats-1.0.2.tgz ...
Starting to download stats-1.0.2.tgz (99,018 bytes)
......................done: 99,018 bytes
17 source files, building
ERROR: The DSP stats.dsp does not exist.
 [2019-10-20 16:13 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-10-20 16:13 UTC] cmb@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

See <https://www.php.net/manual/en/install.pecl.windows.php>.
TL;DR: just download the precompiled DLLs.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Dec 07 02:01:25 2019 UTC