php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #58011 OSX Install Problems Workaround
Submitted: 2008-01-17 10:09 UTC Modified: 2008-08-02 10:39 UTC
From: dirving at workflowbydesign dot com Assigned: mj (profile)
Status: Not a bug Package: Fileinfo (PECL)
PHP Version: 5.2.1 OS: OSX 10.4
Private report: No CVE-ID: None
 [2008-01-17 10:09 UTC] dirving at workflowbydesign dot com
Description:
------------
This is less of a bug report and more of a workaround notification work OSX users. If you happen to be one of the many libmagic error receivers, try the following as root (you  also need to have fink installed):

1. fink install file-shlibs
2. fink install file-dev
3. cp /sw/include/magic.h /usr/include
4. cp /sw/lib/libmagic.1.0.0.dylib /usr/lib
5. ln -s /usr/lib/libmagic.1.0.0.dylib /usr/lib/libmagic.dylib

The above steps worked fine for me and hopefully someone else finds them usefull.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-27 09:12 UTC] kim_chan181 at hotmail dot com
Followed your steps, but still getting "ERROR: `phpize' failed" when I ran "sudo pear -v install pecl/fileinfo".

I tried to install it manually:

> cd /private/tmp/pear/download/Fileinfo-1.0.4
> sudo ./configure
> sudo phpize

After running above command, everything seems find, but still no fileinfo.so.


Have I miss out anything there?
Is there a way to install fileinfo manually?
 [2008-01-27 17:39 UTC] dirving at workflowbydesign dot com
After running the sudo ./configure line, did you do your make and make install? If not, try running (in that same directory):

sudo make; sudo make install
 [2008-08-02 10:39 UTC] mj@php.net
Setting this one to bogus because no fileinfo bug is in there ...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 14:03:37 2021 UTC