php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57962 core dump
Submitted: 2007-12-11 08:19 UTC Modified: 2017-04-01 21:43 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: neo at c dot dk Assigned:
Status: Wont fix Package: syck (PECL)
PHP Version: Irrelevant OS: FreeBSD
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2007-12-11 08:19 UTC] neo at c dot dk
Description:
------------
syck crashes on this yaml file

Reproduce code:
---------------
path.yml:

models : [ /usr/home/enovodk/data/core/easyworks/current/models/ ]
behaviors : [ /usr/home/enovodk/data/core/easyworks/current/models/behaviors/ ]
controllers : [ /usr/home/enovodk/data/core/easyworks/current/controllers/ ]
components : [ /usr/home/enovodk/data/core/easyworks/current/controllers/components/ ]
apis : [ /usr/home/enovodk/data/core/easyworks/current/controllers/api/ ]
views : [ /usr/home/enovodk/data/core/easyworks/current/views/ ]
helpers : [ /usr/home/enovodk/data/core/easyworks/current/views/helpers/ ]
libs : [ /usr/home/enovodk/data/core/easyworks/current/libs/ ]
plugins : [ /usr/home/enovodk/data/core/easyworks/current/plugins/ ]



t.php
<?php
var_dump(syck_load(file_get_contents('path.yml')));


result: dump

Expected result:
----------------
A php array

Actual result:
--------------
Segmentation fault: 11 (core dumped)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-11 08:24 UTC] indeyets at gmail dot com
What version of syck-php is this? It works fine for me with 0.9.2
 [2007-12-11 08:33 UTC] neo at c dot dk
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...(no debugging symbols found)...
Core was generated by `php'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libcrypt.so.4...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypt.so.4
Reading symbols from /lib/libm.so.5...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.5
Reading symbols from /usr/local/lib/libxml2.so.5...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /lib/libz.so.4...(no debugging symbols found)...done.
Loaded symbols for /lib/libz.so.4
Reading symbols from /usr/local/lib/libiconv.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /lib/libc.so.7...(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.7
Reading symbols from /usr/local/lib/php/20060613/pcre.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/pcre.so
Reading symbols from /usr/local/lib/php/20060613/session.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/session.so
Reading symbols from /usr/local/lib/php/20060613/gettext.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/gettext.so
Reading symbols from /usr/local/lib/libintl.so.8...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libintl.so.8
Reading symbols from /usr/local/lib/php/20060613/xml.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/xml.so
Reading symbols from /usr/local/lib/php/20060613/simplexml.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/simplexml.so
Reading symbols from /usr/local/lib/php/20060613/spl.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/spl.so
Reading symbols from /usr/local/lib/php/20060613/dom.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/dom.so
Reading symbols from /usr/local/lib/php/20060613/fileinfo.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/fileinfo.so
Reading symbols from /usr/lib/libmagic.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libmagic.so.3
Reading symbols from /usr/local/lib/php/20060613/hash.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/hash.so
Reading symbols from /usr/local/lib/php/20060613/imap.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/imap.so
Reading symbols from /usr/lib/libssl.so.5...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libssl.so.5
Reading symbols from /lib/libcrypto.so.5...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypto.so.5
Reading symbols from /usr/local/lib/libc-client4.so.9...done.
Loaded symbols for /usr/local/lib/libc-client4.so.9
Reading symbols from /usr/lib/libpam.so.4...done.
Loaded symbols for /usr/lib/libpam.so.4
Reading symbols from /usr/local/lib/php/20060613/json.so...done.
Loaded symbols for /usr/local/lib/php/20060613/json.so
Reading symbols from /usr/local/lib/php/20060613/posix.so...done.
Loaded symbols for /usr/local/lib/php/20060613/posix.so
Reading symbols from /usr/local/lib/php/20060613/sockets.so...done.
Loaded symbols for /usr/local/lib/php/20060613/sockets.so
Reading symbols from /usr/local/lib/php/20060613/tokenizer.so...done.
Loaded symbols for /usr/local/lib/php/20060613/tokenizer.so
Reading symbols from /usr/local/lib/php/20060613/xmlreader.so...done.
Loaded symbols for /usr/local/lib/php/20060613/xmlreader.so
Reading symbols from /usr/local/lib/php/20060613/xmlwriter.so...done.
Loaded symbols for /usr/local/lib/php/20060613/xmlwriter.so
Reading symbols from /usr/local/lib/php/20060613/xsl.so...done.
Loaded symbols for /usr/local/lib/php/20060613/xsl.so
Reading symbols from /usr/local/lib/libexslt.so.8...done.
Loaded symbols for /usr/local/lib/libexslt.so.8
Reading symbols from /usr/local/lib/libxslt.so.2...done.
Loaded symbols for /usr/local/lib/libxslt.so.2
Reading symbols from /usr/local/lib/php/20060613/zip.so...done.
Loaded symbols for /usr/local/lib/php/20060613/zip.so
Reading symbols from /usr/local/lib/php/20060613/pgsql.so...done.
Loaded symbols for /usr/local/lib/php/20060613/pgsql.so
Reading symbols from /usr/local/lib/libpq.so.5...done.
Loaded symbols for /usr/local/lib/libpq.so.5
Reading symbols from /lib/libthr.so.3...done.
Loaded symbols for /lib/libthr.so.3
Reading symbols from /usr/local/lib/php/20060613/memcache.so...done.
Loaded symbols for /usr/local/lib/php/20060613/memcache.so
Reading symbols from /usr/local/lib/php/20060613/mysql.so...done.
Loaded symbols for /usr/local/lib/php/20060613/mysql.so
Reading symbols from /usr/local/lib/mysql/libmysqlclient.so.15...done.
Loaded symbols for /usr/local/lib/mysql/libmysqlclient.so.15
Reading symbols from /usr/local/lib/php/20060613/mysqli.so...done.
Loaded symbols for /usr/local/lib/php/20060613/mysqli.so
Reading symbols from /usr/local/lib/php/20060613/apc.so...done.
Loaded symbols for /usr/local/lib/php/20060613/apc.so
Reading symbols from /usr/lib/librt.so.1...done.
Loaded symbols for /usr/lib/librt.so.1
Reading symbols from /usr/local/lib/php/20060613/syck.so...done.
Loaded symbols for /usr/local/lib/php/20060613/syck.so
Reading symbols from /libexec/ld-elf.so.1...done.
Loaded symbols for /libexec/ld-elf.so.1
#0  0x0000000803b92e5e in syck_map_update () from /usr/local/lib/php/20060613/syck.so
[New Thread 0x8012c9120 (LWP 100208)]
(gdb) bt
#0  0x0000000803b92e5e in syck_map_update () from /usr/local/lib/php/20060613/syck.so
#1  0x0000000803b95738 in syckparse () from /usr/local/lib/php/20060613/syck.so
#2  0x0000000803b93d1b in syck_parse () from /usr/local/lib/php/20060613/syck.so
#3  0x0000000803b8e737 in zif_syck_load (ht=Variable "ht" is not available.
) at /root/syck-0.9.2/phpext.c:826
#4  0x00000000005350d2 in zend_do_fcall_common_helper_SPEC ()
#5  0x0000000000525fa3 in execute ()
#6  0x0000000000506f13 in zend_execute_scripts ()
#7  0x00000000004c528d in php_execute_script ()
#8  0x0000000000587976 in main ()
(gdb)
 [2017-04-01 21:43 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:43 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2008, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 03 10:01:24 2020 UTC