php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57956 warning: comparison with string literal results in unspecified behavior
Submitted: 2007-12-06 21:49 UTC Modified: 2008-01-14 19:16 UTC
From: crrodriguez at suse dot de Assigned:
Status: Closed Package: intl (PECL)
PHP Version: Irrelevant OS: linux
Private report: No CVE-ID: None
 [2007-12-06 21:49 UTC] crrodriguez at suse dot de
Description:
------------
locale/locale_methods.c on lines 261, 265, 276, 305, 308, 311, 314, 317, 510, 514, 556, 559, 562, 565, 568, 800, 851, 854, 857, 1040, 1046, 1072 emit the mentioned compile warning with newer GCC versions, Usuallystrcmp() was intended by the programmer.



Reproduce code:
---------------
compile the extension with recent GCC.

Expected result:
----------------
No warnings.

Actual result:
--------------
unspecified behavior warnings.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-12 15:56 UTC] stas at zend dot com
which gcc version are you using? any special options? I do not see the warnings on gcc 4.1.2
 [2007-12-12 16:24 UTC] crrodriguez at suse dot de
This warnings appear with new gcc 4.2.x or later.
 [2008-01-14 19:16 UTC] kirtig at yahoo-inc dot com
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

Fixed in CVS .
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Sep 27 17:01:24 2020 UTC