php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57948 ERROR: The DSP Fileinfo.dsp does not exist
Submitted: 2007-12-03 14:32 UTC Modified: 2017-09-20 11:58 UTC
Votes:4
Avg. Score:4.5 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:2 (66.7%)
From: lars at legestue dot net Assigned: cmb (profile)
Status: Closed Package: *General Issues
PHP Version: 5.2.1 OS: Windows Vista
Private report: No CVE-ID: None
 [2007-12-03 14:32 UTC] lars at legestue dot net
Description:
------------
I am on Windows Vista with PHP 5.2.4 (seems the bugtracker is a bit out of date), and I am using this install code:

pecl install FileInfo

It downloads the package, writes:

3 source files, building
ERROR: The DSP Fileinfo.dsp does not exist

And that is the end of it. Any way to avoid this?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-03 13:04 UTC] tzenk at gmx dot net
I can confirm that trying to install the uploadprogress on winxp throws the following error message on command line:

path\php>pecl install uploadprogress
downloading uploadprogress-1.0.0.tgz ...
Starting to download uploadprogress-1.0.0.tgz (7,7
.....done: 7,761 bytes
3 source files, building
ERROR: The DSP uploadprogress.dsp does not exist.

Has someone got any clue how to get this  DSP file?

Best Regards
Torsten Zenk
 [2010-10-25 23:39 UTC] sam at archives dot org dot au
I too was getting the "The DSP Fileinfo.dsp does not exist" error, on Windows Server 2003, and solved it by installing the php_fileinfo.dll from PHP 5.2.5.

(See http://samwilson.id.au/2010/10/26/fileinfo/ for more details.)
 [2012-04-19 22:52 UTC] brent dot newland at casipc dot com
This bug is the root cause of the problem: http://pear.php.net/bugs/bug.php?id=17016
 [2017-09-20 11:58 UTC] cmb@php.net
-Status: Open +Status: Closed -Package: Fileinfo +Package: *General Issues -Assigned To: +Assigned To: cmb
 [2017-09-20 11:58 UTC] cmb@php.net
PECL/fileinfo is unmaintened as of PHP 5.3.0, so this ticket can be closed.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Oct 01 15:03:57 2022 UTC