php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57932 building imagick ext
Submitted: 2007-11-28 10:37 UTC Modified: 2008-01-08 08:46 UTC
From: sskaje at gmail dot com Assigned:
Status: Not a bug Package: imagick (PECL)
PHP Version: Irrelevant OS: Windows 2003
Private report: No CVE-ID: None
 [2007-11-28 10:37 UTC] sskaje at gmail dot com
Description:
------------
I downloaded IMagick and tried to compile it with my php 5.2.5 as i didnt see the php_imagick.dll in the pecl 5.2.5.
i tried all recent versions, all of them get a link error when building with ms vc 6.
The ImageMagick i use is 6.3.7.1, the latest version.

this is the error message:

[code]
Linking...
   Creating library Release_TS/php_imagick.lib and object Release_TS/php_imagick.exp
imagick.obj : error LNK2001: unresolved external symbol _executor_globals_id
imagick.obj : error LNK2001: unresolved external symbol _zend_ce_iterator
..\..\Release_TS/php_imagick.dll : fatal error LNK1120: 2 unresolved externals
Error executing link.exe.
[/code]

php5ts.lib has been copied from php5.2.4-win32/dev/ to the phpsource/ext/imagick/


could someone please help me with it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-01 06:14 UTC] wiesemann@php.net
(wrong package)
 [2008-01-01 06:17 UTC] sskaje at gmail dot com
i know that you mean teh php5ts.lib of php-5.2.4-win32
i tried the one from php 5.2.5 and even compiled one myself

none of those works
 [2008-01-01 06:29 UTC] sskaje at gmail dot com
the building message of vc 6
http://pastebin.com/f49039896

the file tree of the /ext/imagick/
http://pastebin.com/f7c887a24

the content of the dsp file (i just fixed the Release part)
http://pastebin.com/f3931e756
 [2008-01-08 08:46 UTC] mkoppanen@php.net
Can you send me your VS template? I am changing the bug status to bogus because this is not a bug in Imagick.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC