php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57902 Cursor leak when LOB fields are selected
Submitted: 2007-11-08 18:27 UTC Modified: 2007-11-08 18:36 UTC
From: martin at catalyst dot net dot nz Assigned:
Status: Duplicate Package: oci8 (PECL)
PHP Version: 5.2.1 OS: Linux Ubuntu Gutsy
Private report: No CVE-ID: None
 [2007-11-08 18:27 UTC] martin at catalyst dot net dot nz
Description:
------------
Reproduceable with
 - Ubuntu Gutsy (also seen on SuSE 10, Debian Etch)
 - PHP 5.2.3 (gutsy packages on i386)
 - OCI8 v1.2.4 and v1.3.0 Beta (as of today)
 - OCI8 v1.2.3 works correctly

OCI_Free_Statement() fails to release cursors if the resultset contained LOBs.

Also reported here with a good repro script...
http://bugs.php.net/bug.php?id=42496

And here...
http://tracker.moodle.org/browse/MDL-11429

Reproduce code:
---------------
See http://tracker.moodle.org/browse/MDL-11429


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-08 18:36 UTC] christopher dot jones at oracle dot com
------------
Likely to be a duplicate of http://bugs.php.net/bug.php?id=42496
Please update that bug with any new information or testcases.
------------
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Nov 23 02:01:24 2019 UTC