php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57841 No rule to make target... ext/http/missing.c
Submitted: 2007-09-14 14:45 UTC Modified: 2007-09-17 05:31 UTC
From: artimus at eresmas dot net Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5_2 CVS-2007-09-14 OS: Mac Os X Server 10.4.10
Private report: No CVE-ID: None
 [2007-09-14 14:45 UTC] artimus at eresmas dot net
Description:
------------
Hi.This are my steps: pre-installed pecl_http in ext.
After builconf I notice this warning:
ext/pecl_http/config.m4:5: warning: file `config9.m4' 
included 
several times
I proceed with compile PHP5.2.4 without errors:
 ... --enable-http=shared 
--with-http-zlib-compression=/usr  
--with-http-magic-mime=shared,/sw 
--with-http-curl-
requests=shared,/usr  ...
after this, the make process stoped looking for an 
inexistent 
http folder in ext. I don't know if the correct folder would 
be the pecl_http folder.

Reproduce code:
---------------
make: *** No rule to make target `/installs/php5/php-5.2.4/
ext/http/missing.c', needed by `ext/http/missing.lo'.  Stop.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-17 05:11 UTC] mike@php.net
Well, that might be because the extensions internal name is just "http" it's PECL name is pecl_http because of PEAR::HTTP.

$ mv pecl_http http
$ ./buildconf

...should fix it.
 [2007-09-17 05:31 UTC] artimus at eresmas dot net
Yes, When a renamed to http, the make process works.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 06:03:37 2021 UTC