php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57776 Error installing ssh2-0.10
Submitted: 2007-08-07 04:37 UTC Modified: 2008-12-20 12:31 UTC
From: arstan at jusupov dot com Assigned:
Status: Closed Package: ssh2 (PECL)
PHP Version: 5.2.1 OS: Fedora 7
Private report: No CVE-ID:
 [2007-08-07 04:37 UTC] arstan at jusupov dot com
Description:
------------
PHP Version 5.2.2
PECL ssh2-0.10.tgz
gcc 4.1.2

Reproduce code:
---------------
[root@vm1 ssh2-0.10]# phpize && ./configure --with-ssh2 && make
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib
checking for PHP extension directory... /usr/lib/php/modules
checking for PHP installed headers prefix... /usr/include/php
checking for re2c... no
configure: WARNING: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for ssh2 support... yes, shared
checking for ssh2 files in default path... found in /usr/local
checking for libssh2_banner_set in -lssh2... yes
checking for libssh2_channel_forward_listen_ex in -lssh2... yes
checking for libssh2_userauth_hostbased_fromfile_ex in -lssh2... yes
checking for libssh2_poll in -lssh2... yes
checking for libssh2_publickey_init in -lssh2... yes
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
appending configuration tag "F77" to libtool
configure: creating ./config.status
config.status: creating config.h
/bin/sh /root/ssh2-0.10/libtool --mode=compile gcc  -I. -I/root/ssh2-0.10 -DPHP_ATOM_INC -I/root/ssh2-0.10/include -I/root/ssh2-0.10/main -I/root/ssh2-0.10 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -I/usr/local/include  -DHAVE_CONFIG_H  -g -O2   -c /root/ssh2-0.10/ssh2.c -o ssh2.lo 
mkdir .libs
 gcc -I. -I/root/ssh2-0.10 -DPHP_ATOM_INC -I/root/ssh2-0.10/include -I/root/ssh2-0.10/main -I/root/ssh2-0.10 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -I/usr/local/include -DHAVE_CONFIG_H -g -O2 -c /root/ssh2-0.10/ssh2.c  -fPIC -DPIC -o .libs/ssh2.o
/root/ssh2-0.10/ssh2.c: In function 'zif_ssh2_methods_negotiated':
/root/ssh2-0.10/ssh2.c:481: warning: passing argument 2 of 'libssh2_session_methods' makes integer from pointer without a cast
/root/ssh2-0.10/ssh2.c:481: error: too many arguments to function 'libssh2_session_methods'
/root/ssh2-0.10/ssh2.c: In function 'zif_ssh2_fingerprint':
/root/ssh2-0.10/ssh2.c:536: warning: assignment discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c: In function 'zif_ssh2_publickey_add':
/root/ssh2-0.10/ssh2.c:1038: warning: passing argument 1 of '_efree' discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c: In function 'zif_ssh2_publickey_list':
/root/ssh2-0.10/ssh2.c:1097: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c:1098: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c:1106: warning: initialization discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c:1107: warning: passing argument 2 of '_zend_hash_add_or_update' discards qualifiers from pointer target type
make: *** [ssh2.lo] Error 1

Also tried Bug #4756


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-07 12:15 UTC] oeriksson at mandriva dot com
Since libssh2-0.16 I think this will fix the build:

--- ssh2.c      2006-06-07 19:35:34.000000000 +0200
+++ ssh2.c.oden 2007-08-07 17:32:29.000000000 +0200
@@ -484,7 +484,7 @@

        ZEND_FETCH_RESOURCE(session, LIBSSH2_SESSION*, &zsession, -1, PHP_SSH2_SESSION_RES_NAME, le_ssh2_session);

-#if LIBSSH2_APINO < 200412301450
+#if LIBSSH2_VERSION_NUM < 0x001000
        libssh2_session_methods(session, &kex, &hostkey, &crypt_cs, &crypt_sc, &mac_cs, &mac_sc, &comp_cs, &comp_sc, &lang_cs, &lang_sc);
 #else
        kex = libssh2_session_methods(session, LIBSSH2_METHOD_KEX);
 [2007-09-05 19:15 UTC] info at adaniels dot nl
Also does not work on Ubuntu Feisty using PHP 5.2.4 and libssh 0.17. Please mark this bug as critical and fix as soon as possible.
 [2007-09-06 09:52 UTC] brian at ehnii dot net
yep, not working on Ubuntu Feisty with PHP 5.2.1 and libssh2 0.17
 [2007-09-07 14:38 UTC] adam-peclbugs at adam dot gs
Not working with libssh2-0.17 or latest svn snap on OSX (x86 
or ppc) either
 [2007-09-25 14:59 UTC] bcavalieri at lumensoftware dot com
oeriksson - Thanks for the above patch, builds great with libssh2 0.17 and PHP5 5.2.4.
 [2007-09-28 10:23 UTC] spam2 at rhsoft dot net
Can anybody make a download for 0.11 available - sorry but im php-developer and can not really good work with c-diffs :-(

Why is the pecl-package not updated since two years?
 [2007-09-28 22:39 UTC] grifty at gmail dot com
I had the same problem, but the patch from oeriksson solved it for me. Debian Sarge

His link died, here's an updated one: http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/php-ssh2/pristine/SOURCES/
 [2007-10-04 07:48 UTC] samrat1004 at gmail dot com
test:~/ssh2-0.10# phpize && ./configure --with-ssh2 && make
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
checking for PHP extension directory... /usr/lib/php5/20060613+lfs
checking for PHP installed headers prefix... /usr/include/php5
checking for re2c... no
configure: WARNING: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for ssh2 support... yes, shared
checking for ssh2 files in default path... found in /usr/local
checking for libssh2_banner_set in -lssh2... yes
checking for libssh2_channel_forward_listen_ex in -lssh2... yes
checking for libssh2_userauth_hostbased_fromfile_ex in -lssh2... yes
checking for libssh2_poll in -lssh2... yes
checking for libssh2_publickey_init in -lssh2... yes
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
configure: creating ./config.status
config.status: creating config.h
config.status: config.h is unchanged
/bin/sh /root/ssh2-0.10/libtool --mode=compile gcc  -I. -I/root/ssh2-0.10 -DPHP_ATOM_INC -I/root/ssh2-0.10/include -I/root/ssh2-0.10/main -I/root/ssh2-0.10 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/local/include  -DHAVE_CONFIG_H  -g -O2   -c /root/ssh2-0.10/ssh2.c -o ssh2.lo
mkdir .libs
 gcc -I. -I/root/ssh2-0.10 -DPHP_ATOM_INC -I/root/ssh2-0.10/include -I/root/ssh2-0.10/main -I/root/ssh2-0.10 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/local/include -DHAVE_CONFIG_H -g -O2 -c /root/ssh2-0.10/ssh2.c -fPIC -DPIC -o .libs/ssh2.o
/root/ssh2-0.10/ssh2.c: In function 'zif_ssh2_methods_negotiated':
/root/ssh2-0.10/ssh2.c:472: warning: passing argument 2 of 'libssh2_session_methods' makes integer from pointer without a cast
/root/ssh2-0.10/ssh2.c:472: error: too many arguments to function 'libssh2_session_methods'
/root/ssh2-0.10/ssh2.c: In function 'zif_ssh2_fingerprint':
/root/ssh2-0.10/ssh2.c:527: warning: assignment discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c: In function 'zif_ssh2_publickey_add':
/root/ssh2-0.10/ssh2.c:1029: warning: passing argument 1 of '_efree' discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c: In function 'zif_ssh2_publickey_list':
/root/ssh2-0.10/ssh2.c:1088: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c:1089: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c:1097: warning: initialization discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c:1098: warning: passing argument 2 of '_zend_hash_add_or_update' discards qualifiers from pointer target type
/root/ssh2-0.10/ssh2.c: At top level:
/root/ssh2-0.10/ssh2.c:1284: error: 'php_ssh2_first_arg_force_ref' undeclared here (not in a function)
make: *** [ssh2.lo] Error 1

what should i do can anyone pls help me as i have to install the SSH2 module for PHP and activate it in my php.ini!
i desperately need solution as i am waste my lots of time already looking for solution
 [2007-10-09 00:20 UTC] samrat at gmail dot com
as u mention earlier:

the patch from oeriksson solved it for me.
Debian Sarge

His link died, here's an updated one:
http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/php-ssh2/pris
tine/SOURCES/

but it seeme to that this link is also died
so pls help me as i am stuck into that error from many days



/root/ssh2-0.10/ssh2.c:1284: error: 'php_ssh2_first_arg_force_ref'
undeclared here (not in a function)
make: *** [ssh2.lo] Error 1

what should i do as i have to install the SSH2
module for PHP and activate it in my php.ini!
i desperately need solution as i am waste my lots of time already
looking for solution
 [2007-10-25 15:36 UTC] wyldie28 at hotmail dot com
samrat

presuming you've downloaded, and extracted the pecl lib you can patch it manually by opening up ssh2.c running down the script till you get to the line that reads:

  #if LIBSSH2_APINO < 200412301450

Change it to read

  #if LIBSSH2_VERSION_NUM < 0x001000

Save the file and run

  phpize && ./configure --with-ssh2 && make

Then carry on from there. You'll now need to edit your PHP.INI to load in the extension, but you should be good to go.
 [2007-12-25 09:51 UTC] shaike dot katz at huji dot ac dot il
wyldie28,

changing the ssh2.c file worked for me on Fedora 8.

Thanks
 [2008-01-23 02:31 UTC] mark at nexway dot com
Hello,

I had the same problem. Modifying the source in ssh2.c fixed the problem for me (gentoo 2007.0 with libssh2 0.18).

This should be released (with a more conditionnal thing for compatibility with older releases, maybe, like #if (defined(BLAH) && BLAH > x) || (defined(BLAH2) && BLAH2 > x)
 [2008-01-24 03:30 UTC] harald at clipdealer dot de
successfully applied this patch on OSX 10.4.11, PHP5.2.5, libssh2-0.18.
 [2008-04-29 15:18 UTC] beanjammin at gmail dot com
Thanks, editing ssh2.c as above did the trick on Debian Etch
 [2008-06-01 22:56 UTC] yosnoop at gmail dot com
confirmed ssh2.c patch on centos5
 [2008-06-21 03:36 UTC] wes at uresu dot com
Can we get this bug implemented and relased into .11 please :)
 [2008-07-25 12:43 UTC] david dot merel at gmail dot com
I installed  ssh2-0.11 from the source repository and I am now getting the following, I dont know what to do, it looks like this is completely corrupted or something, it simply wont connnect and I have tried this is on other servers and they worked.

The only difference between this server and others is this is on FC4, anybody know issues of SSH2 and Libssh2 on FC4?

Warning: ssh2_connect() [function.ssh2-connect]: Unable to connect to 192.168.1.116 on port 22 in /var/www/html/send.php on line 3

Warning: ssh2_connect() [function.ssh2-connect]: Unable to connect to 192.168.1.116 in /var/www/html/send.php on line 3

Warning: ssh2_auth_password() expects parameter 1 to be resource, boolean given in /var/www/html/send.php on line 4

Warning: ssh2_scp_send() expects parameter 1 to be resource, boolean given in /var/www/html/send.php on line 6
finished
 [2008-10-17 16:16 UTC] eu at moacirbispo dot com dot br
attention: ssh2-0.10.tgz need libssh2 version 0.14! On the Ubuntu 8.04 the libssh2 using libssh2 0.18 . To correct work, uninstall the libssh2 0.18 and download source libssh2 0.14 in the http://sourceforge.net/projects/libssh2/ compile and install. Good luck!
 [2008-11-15 20:39 UTC] mark at unused dot net
Thanks, this is definitely a bug. Uninstalling .18 and installing .14 worked great for me.
 [2008-12-03 11:12 UTC] pip_winfield at yahoo dot com
Successfully applied oeriksson's patch on CentOs 2.6.18-53.1.14.el5 running PHP 5.2.3
 [2008-12-20 12:31 UTC] mikesul@php.net
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/ssh2


 [2010-09-21 11:36 UTC] mmb at netgate dot com dot uy
hello

when I make the "make", I get this

/bin/sh /usr/marce/ssh2-0.10/libtool --mode=compile cc  -I. -I/usr/marce/ssh2-0.10 -DPHP_ATOM_INC -I/usr/marce/ssh2-0.10/include -I/usr/marce/ssh2-0.10/main -I/usr/marce/ssh2-0.10 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/local/include  -DHAVE_CONFIG_H  -g -O2   -c /usr/marce/ssh2-0.10/ssh2.c -o ssh2.lo
mkdir .libs
 cc -I. -I/usr/marce/ssh2-0.10 -DPHP_ATOM_INC -I/usr/marce/ssh2-0.10/include -I/usr/marce/ssh2-0.10/main -I/usr/marce/ssh2-0.10 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/local/include -DHAVE_CONFIG_H -g -O2 -c /usr/marce/ssh2-0.10/ssh2.c  -fPIC -DPIC -o .libs/ssh2.o
/usr/marce/ssh2-0.10/ssh2.c:49: error: duplicate 'static'
/usr/marce/ssh2-0.10/ssh2.c: In function 'zif_ssh2_methods_negotiated':
/usr/marce/ssh2-0.10/ssh2.c:483: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:484: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:485: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:486: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:487: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:488: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:489: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:490: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:491: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:492: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c: In function 'zif_ssh2_fingerprint':
/usr/marce/ssh2-0.10/ssh2.c:536: warning: assignment discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c: In function 'zif_ssh2_poll':
/usr/marce/ssh2-0.10/ssh2.c:885: error: 'zval' has no member named 'is_ref'
/usr/marce/ssh2-0.10/ssh2.c:885: error: 'zval' has no member named 'refcount'
/usr/marce/ssh2-0.10/ssh2.c:895: error: 'zval' has no member named 'is_ref'
/usr/marce/ssh2-0.10/ssh2.c:896: error: 'zval' has no member named 'refcount'
/usr/marce/ssh2-0.10/ssh2.c: In function 'zif_ssh2_publickey_add':
/usr/marce/ssh2-0.10/ssh2.c:1005: error: 'zval' has no member named 'is_ref'
/usr/marce/ssh2-0.10/ssh2.c:1006: error: 'zval' has no member named 'refcount'
/usr/marce/ssh2-0.10/ssh2.c:1038: warning: passing argument 1 of '_efree' discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c: In function 'zif_ssh2_publickey_list':
/usr/marce/ssh2-0.10/ssh2.c:1097: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/usr/marce/ssh2-0.10/ssh2.c:1098: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
make: *** [ssh2.lo] Error 1


I have already applied many patches and edited the ssh2.c but still getting it... I have ran out of ideas
can you help me out?

thanks in advance
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC