php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57726 compilation syntax error
Submitted: 2007-06-30 08:56 UTC Modified: 2007-07-04 03:41 UTC
From: mailbinoyv at gmail dot com Assigned:
Status: Not a bug Package: PDO (PECL)
PHP Version: 5.2.1 OS: CentOS release 4.5
Private report: No CVE-ID: None
 [2007-06-30 08:56 UTC] mailbinoyv at gmail dot com
Description:
------------
I am trying to compile pdo 1.0.3 against a custom php 5.2.1. i get the following error when compiling

# ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20020429
checking for re2c... exit 0;
checking for gawk... gawk
checking whether to enable PDO support... yes, shared
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking command to parse /usr/bin/nm -B output... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking whether -lc should be explicitly linked in... no
creating libtool
configure: creating ./config.status
config.status: creating config.h


# make
/bin/sh /root/PDO-1.0.3/libtool --mode=compile gcc  -I. -I/root/PDO-1.0.3 -DPHP_ATOM_INC -I/root/PDO-1.0.3/include -I/root/PDO-1.0.3/main -I/root/PDO-1.0.3 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend  -DHAVE_CONFIG_H  -g -O2   -c /root/PDO-1.0.3/pdo.c -o pdo.lo
gcc -I. -I/root/PDO-1.0.3 -DPHP_ATOM_INC -I/root/PDO-1.0.3/include -I/root/PDO-1.0.3/main -I/root/PDO-1.0.3 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -DHAVE_CONFIG_H -g -O2 -c /root/PDO-1.0.3/pdo.c  -fPIC -DPIC -o pdo.lo
In file included from /root/PDO-1.0.3/pdo.c:32:
/root/PDO-1.0.3/php_pdo_driver.h:605: error: syntax error before "zend_fcall_info"
/root/PDO-1.0.3/php_pdo_driver.h:605: warning: no semicolon at end of struct or union
/root/PDO-1.0.3/php_pdo_driver.h:605: warning: no semicolon at end of struct or union
/root/PDO-1.0.3/php_pdo_driver.h:606: warning: no semicolon at end of struct or union
/root/PDO-1.0.3/php_pdo_driver.h:607: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_driver.h:612: error: syntax error before "zend_fcall_info"
/root/PDO-1.0.3/php_pdo_driver.h:612: warning: no semicolon at end of struct or union
/root/PDO-1.0.3/php_pdo_driver.h:613: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_driver.h:615: error: syntax error before '}' token
/root/PDO-1.0.3/php_pdo_driver.h:615: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_driver.h:617: error: syntax error before '}' token
/root/PDO-1.0.3/php_pdo_driver.h:617: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_driver.h:622: error: syntax error before '}' token
In file included from /root/PDO-1.0.3/pdo.c:33:
/root/PDO-1.0.3/php_pdo_int.h:34: error: syntax error before "pdo_dbh_new"
/root/PDO-1.0.3/php_pdo_int.h:34: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_int.h:39: error: syntax error before "pdo_dbstmt_new"
/root/PDO-1.0.3/php_pdo_int.h:39: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_int.h:43: error: syntax error before '*' token
/root/PDO-1.0.3/php_pdo_int.h:43: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_int.h:44: error: syntax error before "pdo_dbstmt_object_handlers"
/root/PDO-1.0.3/php_pdo_int.h:44: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_int.h:48: error: syntax error before "pdo_row_new"
/root/PDO-1.0.3/php_pdo_int.h:48: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_int.h:52: error: syntax error before "pdo_row_object_handlers"
/root/PDO-1.0.3/php_pdo_int.h:52: warning: data definition has no type or storage class
/root/PDO-1.0.3/php_pdo_int.h:54: error: syntax error before '*' token
/root/PDO-1.0.3/php_pdo_int.h:54: warning: data definition has no type or storage class
/root/PDO-1.0.3/pdo.c:34:29: zend_exceptions.h: No such file or directory
/root/PDO-1.0.3/pdo.c: In function `php_pdo_get_exception_base':
/root/PDO-1.0.3/pdo.c:78: warning: return makes pointer from integer without a cast
/root/PDO-1.0.3/pdo.c: At top level:
/root/PDO-1.0.3/pdo.c:147: error: `OnUpdateLong' undeclared here (not in a function)
/root/PDO-1.0.3/pdo.c:147: error: initializer element is not constant
/root/PDO-1.0.3/pdo.c:147: error: (near initialization for `ini_entries[0].on_modify')
/root/PDO-1.0.3/pdo.c:147: error: initializer element is not constant
/root/PDO-1.0.3/pdo.c:147: error: (near initialization for `ini_entries[0]')
/root/PDO-1.0.3/pdo.c:148: error: initializer element is not constant
/root/PDO-1.0.3/pdo.c:148: error: (near initialization for `ini_entries[1]')
/root/PDO-1.0.3/pdo.c: In function `zm_startup_pdo':
/root/PDO-1.0.3/pdo.c:325: error: `ZEND_ACC_PUBLIC' undeclared (first use in this function)
/root/PDO-1.0.3/pdo.c:325: error: (Each undeclared identifier is reported only once
/root/PDO-1.0.3/pdo.c:325: error: for each function it appears in.)
make: *** [pdo.lo] Error 1
root@clark [~/PDO-1.0.3]#



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-07-03 01:48 UTC] mailbinoyv at gmail dot com
any update/suggestions  on this.
 [2007-07-04 03:41 UTC] mailbinoyv at gmail dot com
my bad. this is not a bug.
 [2007-07-27 16:40 UTC] jshuler at shulerent dot com
Could you please explain how you were able to resolve the situation? I am having the same problem.
 [2007-07-27 16:46 UTC] jshuler at shulerent dot com
Got it. I have two versions of php. I used phpize from php 4, and as such was trying to compile it against php4.

Make sure your path is setup correctly.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 21:01:24 2020 UTC