php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57722 Incompatible with latest release of libssh2
Submitted: 2007-06-26 07:24 UTC Modified: 2008-12-20 12:33 UTC
From: lobbin at gmail dot com Assigned:
Status: Closed Package: ssh2 (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2007-06-26 07:24 UTC] lobbin at gmail dot com
Description:
------------
After upgrading libssh2 to the recent 0.15 release, the ssh2 
module isn't working.

PHP Warning:  dl(): Unable to load dynamic library '/usr/lib/
php4/ssh2.so' - /usr/lib/php4/ssh2.so: undefined symbol: 
libssh2_sftp_readdir

Checking the lib with nm tells me the function is renamed:
00015110 T libssh2_sftp_readdir_ex


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-28 10:13 UTC] spam2 at rhsoft dot net
Same on Fedora 7 with libssh2-0.17-1.fc7.rf and libssh2-devel-0.17-1.fc7.rf installed.

/development/src/php-ext/ssh2/ssh2.c: In function 'zif_ssh2_methods_negotiated':
/development/src/php-ext/ssh2/ssh2.c:481: warning: passing argument 2 of 'libssh2_session_methods' makes integer from pointer without a cast
/development/src/php-ext/ssh2/ssh2.c:481: error: too many arguments to function 'libssh2_session_methods'
/development/src/php-ext/ssh2/ssh2.c: In function 'zif_ssh2_fingerprint':
/development/src/php-ext/ssh2/ssh2.c:536: warning: assignment discards qualifiers from pointer target type
/development/src/php-ext/ssh2/ssh2.c: In function 'zif_ssh2_publickey_add':
/development/src/php-ext/ssh2/ssh2.c:1038: warning: passing argument 1 of '_efree' discards qualifiers from pointer target type
/development/src/php-ext/ssh2/ssh2.c: In function 'zif_ssh2_publickey_list':
/development/src/php-ext/ssh2/ssh2.c:1097: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/development/src/php-ext/ssh2/ssh2.c:1098: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/development/src/php-ext/ssh2/ssh2.c:1106: warning: initialization discards qualifiers from pointer target type
/development/src/php-ext/ssh2/ssh2.c:1107: warning: passing argument 2 of '_zend_hash_add_or_update' discards qualifiers from pointer target type
make: *** [ssh2.lo] Fehler 1

Hope this will build again soon becaue the extensions date is very old and i need the functions for copy data on a client-remoteserver per cron-job from an php-application
________

On MacOSX with ZendCore and source-build of libssh2 ist also the same.

But there are some other problems also with older versions, compiles fine, will be shown in phpinfo() but after the first call auf a ssh-function php dies away - but this time im not sure if the problem is zendcore, libssh2 or the extension himself
 [2007-11-26 11:55 UTC] i dot galic at brainsware dot org
Judging from the only error I see in this compile, this patch http://pecl.php.net/bugs/bug.php?id=11811 should fix this problem as well.
 [2008-12-20 12:33 UTC] mikesul@php.net
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/ssh2


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 03:01:28 2019 UTC