php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57712 continue bug #4682 with a new bug
Submitted: 2007-06-19 20:38 UTC Modified: 2013-06-28 07:04 UTC
From: roberto at spadim dot com dot br Assigned: shm (profile)
Status: Closed Package: ffi (PECL)
PHP Version: 5.2.1 OS: linux
Private report: No CVE-ID: None
 [2007-06-19 20:38 UTC] roberto at spadim dot com dot br
Description:
------------
i'm using php 5.2.1
i got cvs of ffi at 2007/06/19
phpize
./configure
and
make

at end of make an error occur

/home/rspadim/php/ffi/teste/pecl/ffi/libffi/src/x86/ffi64.c: In function 'ffi_prep_args':
/home/rspadim/php/ffi/teste/pecl/ffi/libffi/src/x86/ffi64.c:291: error: invalid lvalue in assignment
make: ** [libffi/src/x86/ffi64.lo] Erro 1


Reproduce code:
---------------
phpize
./configure
make



Expected result:
----------------
an extension really beautiful :)

Actual result:
--------------
nothing :(

obs:

Linux version 2.6.20-ARCH (root@workstation64) (gcc version 4.1.2) #1 SMP PREEMPT Thu Mar 22 16:06:38 UTC 2007

64bits machine!
model name      : AMD Athlon(tm) 64 Processor 3000+

archlinux 0.8

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-19 20:47 UTC] roberto at spadim dot com dot br
/bin/sh /home/rspadim/php/ffi/teste/pecl/ffi/libtool --mode=compile gcc -I/home/rspadim/php/ffi/teste/pecl/ffi/libffi/include -I. -I/home/rspadim/php/ffi/teste/pecl/ffi -DPHP_ATOM_INC -I/home/rspadim/php/ffi/teste/pecl/ffi/include -I/home/rspadim/php/ffi/teste/pecl/ffi/main -I/home/rspadim/php/ffi/teste/pecl/ffi -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /home/rspadim/php/ffi/teste/pecl/ffi/libffi/src/x86/ffi64.c -o libffi/src/x86/ffi64.lo
 gcc -I/home/rspadim/php/ffi/teste/pecl/ffi/libffi/include -I. -I/home/rspadim/php/ffi/teste/pecl/ffi -DPHP_ATOM_INC -I/home/rspadim/php/ffi/teste/pecl/ffi/include -I/home/rspadim/php/ffi/teste/pecl/ffi/main -I/home/rspadim/php/ffi/teste/pecl/ffi -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/rspadim/php/ffi/teste/pecl/ffi/libffi/src/x86/ffi64.c  -fPIC -DPIC -o libffi/src/x86/.libs/ffi64.o
/home/rspadim/php/ffi/teste/pecl/ffi/libffi/src/x86/ffi64.c: In function 'ffi_prep_args':
/home/rspadim/php/ffi/teste/pecl/ffi/libffi/src/x86/ffi64.c:291: error: invalid lvalue in assignment
make: ** [libffi/src/x86/ffi64.lo] Erro 1
 [2007-06-19 20:55 UTC] none at noen dot br
invalid lvalue in assignment
THE PROBLEM IS (VOID *)
what should be used?!

  if (ecif->cif->rtype->type != FFI_TYPE_VOID && examine_argument(ecif->cif->rtype, 1, &g, &s) == 0)
    (void *)stack->gpr[gprcount++] = ecif->rvalue;
 [2007-06-19 21:10 UTC] roberto at spadim dot com dot br
i update libffi directory with the cvs of http://sources.redhat.com/libffi/

i could compile
but running examples/files.php
i got an segmentation fault
any idea?
 [2013-06-28 07:04 UTC] shm@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: shm
 [2013-06-28 07:04 UTC] shm@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 09:01:23 2020 UTC