php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57700 utf-8 character encoding problem
Submitted: 2007-06-13 02:33 UTC Modified: 2015-01-09 00:49 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: thelordoweb at gmail dot com Assigned:
Status: Not a bug Package: filter (PECL)
PHP Version: 5.2.1 OS: Linux ubuntu
Private report: No CVE-ID: None
 [2007-06-13 02:33 UTC] thelordoweb at gmail dot com
Description:
------------
Return empty value if use Cyrillic characters in utf-8 encoding.

Reproduce code:
---------------
$sString  =   filter_var($sString,FILTER_SANITIZE_STRING,FILTER_FLAG_STRIP_HIGH);

Expected result:
----------------
Normal string value in utf-8 encoding.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-09 00:49 UTC] ajf@php.net
-Status: Open +Status: Not a bug
 [2015-01-09 00:49 UTC] ajf@php.net
This isn't a bug: UTF-8 characters outside the ASCII range are represented with high-bit bytes. FILTER_FLAG_STRIP_HIGH will get rid of such bytes.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 23:03:34 2021 UTC