php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57691 PDO:SQLite -- PDO::PARAM_LOB problem
Submitted: 2007-06-04 02:32 UTC Modified: 2018-10-26 15:43 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: abcdefg at abcdefg dot hijklmnopq Assigned: cmb (profile)
Status: Duplicate Package: PDO SQLite
PHP Version: 5.2.1 OS: all
Private report: No CVE-ID: None
 [2007-06-04 02:32 UTC] abcdefg at abcdefg dot hijklmnopq
Description:
------------
PDO:SQLite -- PDO::PARAM_LOB problem

PDO::PARAM_LOB is return  stream handle.
but 
 PDO:SQLite -- PDO::PARAM_LOB is
 (sqlite_statement.c) is return string.

http://php.net/manual/en/ref.pdo.php
 -- PDO::PARAM_LOB tells PDO to map the data as a stream



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-18 13:41 UTC] cmb@php.net
-Package: PDO_SQLITE +Package: *General Issues
 [2015-05-18 13:41 UTC] cmb@php.net
Most likely a duplicate of bug #40913.
 [2018-10-26 15:43 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: *General Issues +Package: PDO SQLite -Assigned To: +Assigned To: cmb
 [2018-10-26 15:43 UTC] cmb@php.net
Indeed a duplicate of bug #40913.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 05:01:25 2019 UTC