php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #57657 WSDL Types as Nillable
Submitted: 2007-05-09 08:10 UTC Modified: 2007-06-29 09:04 UTC
From: michael dot caplan at henryschein dot com Assigned: mfp (profile)
Status: Closed Package: SCA_SDO (PECL)
PHP Version: 5.2.1 OS: CentOS 4
Private report: No CVE-ID: None
 [2007-05-09 08:10 UTC] michael dot caplan at henryschein dot com
Description:
------------
The WSDL generator defines all simple types as nillable.  Should that only be the case when the method prototype allows for a parameter to be null?

For reference, see the group discussion thread here: http://groups.google.com/group/phpsoa/browse_thread/thread/d7974caae5ea4986/36a69100978196f5#36a69100978196f5


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-15 12:48 UTC] mfp@php.net
I think we are going to agree that nillable should be signified in the @param or @return as follows:
/**
 * Service for managing email contacts
 *
 * @service
 * @binding.soap
 * @types http://example.org/contacts contacts.xsd
 *
 */
class ContactService {

    /**
     * Retrieve contact details
     *
     * @param string|null $shortname The short name of the contact
     * @return http://example.org/contacts#contact|null The full
contact details
     */
    public function retrieve($shortname) {
    }

}
 [2007-05-23 12:20 UTC] mfp@php.net
I have fixed this in the DUNLIN branch.
 [2007-06-29 09:04 UTC] mfp@php.net
There was discussion about this on phpsoa - the sample below illustrated both the | null idea which is implemented in 1.2.2. and the notion of # to separate name and type which is not. So I am closing this defect. Please feel free to reopen if you find the problem is still there.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 25 02:03:35 2022 UTC