php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57641 imagick_convert fails
Submitted: 2007-04-27 13:48 UTC Modified: 2007-08-03 07:59 UTC
From: ssufficool at rov dot sbcounty dot gov Assigned:
Status: Not a bug Package: imagick (PECL)
PHP Version: 5.2.1 OS: Gentoo 2.6.21
Private report: No CVE-ID: None
 [2007-04-27 13:48 UTC] ssufficool at rov dot sbcounty dot gov
Description:
------------
Converting from TIFF to PNG does not fail, but leaves handle as TIFF

This used to be compiled against graphicsmagick however this doesn't seem to be an option anymor. Imagemagick on Gentoo has a splay tree bug.



Reproduce code:
---------------
imagick_convert( $handle , "PNG" );

Expected result:
----------------
A handle to a PNG image

Actual result:
--------------
Handle reports as image/png but blob magick is "II" which indicates a TIFF.

No errors logged in in php, apache or console.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-27 15:49 UTC] mkoppanen@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.


If you write it on disk do you get a PNG or TIFF image? 
Is your ImageMagick compiled with TIFF support?
When you run "identify -list format" (in shell) can you see TIFF in the list?
 [2007-04-27 15:52 UTC] mkoppanen@php.net
Looks like my comment was discarded. 

1. Run identify -list format in shell. Can you see TIFF in the list? (If not I assume your Imagemagick was not compiled with TIFF support. )

2. If you write the handle to file do you get a TIFF or a PNG file? (Use "file" utility in shell to determine the type)
 [2007-05-01 12:23 UTC] ssufficool at rov dot sbcounty dot gov
identify:
TIFF* TIFF      rw+   Tagged Image File Format (LIBTIFF, Version 3.8.2)

file:
document.png: TIFF image data, little-endian

These files are from multi-paged TIFF documents at 200 DPI monochrome and 11x17.
 [2007-05-04 06:15 UTC] scottmac@php.net
What version of ImageMagick / GraphicsMagick are you using?
 [2007-05-04 11:25 UTC] ssufficool at rov dot sbcounty dot gov
dev-php5/pecl-imagick-0.9.13
media-gfx/graphicsmagick-1.1.7-r3
media-gfx/imagemagick-6.3.3
 [2007-08-03 07:59 UTC] mkoppanen@php.net
Thank you for taking the time to report a problem with the package.
Unfortunately you are not using a current version of the package -- 
the problem might already be fixed. Please download a new
version from http://pecl.php.net/packages.php

If you are able to reproduce the bug with one of the latest
versions, please change the package version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PECL.

Try the latest version.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 12:01:24 2020 UTC