php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57617 Can not load php_ssh2.dll
Submitted: 2007-04-09 11:22 UTC Modified: 2012-06-12 14:35 UTC
From: ryanl at 126 dot com Assigned:
Status: Duplicate Package: ssh2 (PECL)
PHP Version: 5.1.6 OS: winxp sp2
Private report: No CVE-ID: None
 [2007-04-09 11:22 UTC] ryanl at 126 dot com
Description:
------------
Hi,

I download php_ssh2.dll from http://pecl4win.php.net/ext.php/php_ssh2.dll.Then put it into extension dir and add extension=php_ssh2.dll into php.ini.I am sure the setting is correct.

But when I run <?print_r(get_extension_funcs("ssh2"));?>,the result is nothing.None of the SSH2 functions were loader.I add php_smtp.dll in the same way,it's all right.That is why?

The compile log: http://pecl4win.php.net/download.php/elog/6_0/6.0.0/php_ssh2.dll

Is there anyone can help me?

Thanks a lot.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-24 07:37 UTC] nicolas dot lepage at yahoo dot fr
php_ssh2.dll needs the libeay32.dll to work fine.

On my server, I have the "C:/php/" folder added in the PATH environment variable, but it seems it's not enough for the php_ssh2 extension to find libeay32.dll.

You have to copy libeay32.dll in "C:/Windows" or "C:/Windows/system32" folders.

Hope it'll help you.
 [2007-08-23 14:13 UTC] roger at email dot com dot br
Well, I have php directory in PATH and I copied libeay32.dll to \windows\system32, but I still can't get the extension loaded.
Actually, it's Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8d, that report an error:
PHP Startup: Unable to load dynamic library 'C:/Web/Php/ext\php_ssh2.dll' - The operating system could not execute %1. 

PHP version is 5.2.3, the same for the Pecl Pack.
 [2007-08-24 07:32 UTC] roger at email dot com dot br
Using Dependency Walker on php_ssh2.dll, I got an warning message:

Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

The module with problem is C:\Windows\system32\MPR.DLL, which has the function WNetRestoreConnectionA marked as an "unresolved external function". 

All dependencies related to libeay32.dll or ssleay32.dll are ok.
 [2012-06-12 14:35 UTC] langemeijer@php.net
Am I correct in assuming this was a duplicate of bug #57674?
 [2012-06-12 14:35 UTC] langemeijer@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 11 19:01:24 2021 UTC